High CPU usage when moving mouse?

Seb0099

Reputable
Mar 21, 2014
38
0
4,540
1
Hey, first i will say that I'm from Denmark, so there might be some wrong words and so.

My problem is that my CPU usage is going high every time, i move my mouse. Right now i run 28 %, but when i then move my mouse it goes to 65 %.

My mouse is a Razer Deathadder 3.5G and I'm running it at 2000 DPI with Razer Synapse 2.0.
I think the problem with the CPU usage is either Razer Synapse or my hardware.

I can use my Deathadder without Synapse, but it will reset the DPI and the 2 buttons on it. So i can't use them. I have the two buttons to (K) and (G). And i need those to gaming.

I have check the drivers and can't find one, there isn't up-to-date. I have used Ccleaner, Malware Bytes, Avast, Rkill and so on. None of them is showing a malware, if it's the problem.

Specs: (Pakard bell easynote tk11bz
AMD Dual-Core E350
AMD Radeon HD6310
500 GB
2 GB DDR3 ram (getting the last 4 GB in a week or so.)
Windows 7 4 bit

Anyone know what i can do to dis crease CPU usage, when moving my mouse around? And plese reply in steps, so i can understand it better :)
 

clayofthe757

Honorable
Feb 1, 2014
290
0
10,960
50
There isn't any reason that mouse should bog your processor. I recommend removing all software associated with the device and reboot. At that point DPI settings and button usage may be skewed or not functional, but don't worry about it yet. Watch your CPU load as you use it as a 'Generic USB Pointer Device'. If the overuse disappears with the software, then you know instantly that it was the software that was the problem. At that point you can try installing whatever version of the software you can find for. You may need to use older software to accommodate the age of the machine.

Best of luck.
 

Seb0099

Reputable
Mar 21, 2014
38
0
4,540
1


When I'm surfing on the internet, there is only the "maxthon 3" procceses opened.

When i game i think its Svchost. Yesterday when i played css, fps falled to 13 fps and svchost was using 70% CPU. Never happend before.

I know when i'm browseing that maxthon uses some CPU, but gets only high when moveing mouse or multiple tabs.
 

Seb0099

Reputable
Mar 21, 2014
38
0
4,540
1


ok, i will try that and come with a result.
 

clayofthe757

Honorable
Feb 1, 2014
290
0
10,960
50


I'm not familiar with the make. Try older drivers/software if you have the option.

Still, I wish you luck.
 

Seb0099

Reputable
Mar 21, 2014
38
0
4,540
1


I just wana say that the problem is fixed for now. I installed the lastest driver version (3.05) beore Razer Synapse came out. It's working fine and my CPU usage isn't going mad every time i move the mouse. Thanks for the help.
 

clayofthe757

Honorable
Feb 1, 2014
290
0
10,960
50


You're very welcome. Choose my answer as the solution if you think it is appropriate.
 

Vydrysek

Reputable
May 20, 2014
1
0
4,510
0
Hey. I finally managed to find a relevant thread to this issue.

Same thing happened to me recently: my PC was going nuts, not even being able to move the mouse properly, task manager taking forever to start, folders not opening and such. It'd take for 1-5 minutes to "cool down". I found out that System CPU usage was around 30% but never thought it could be Razer Synapse or my mouse (since I also am using a Deathadder 3.5G).

Next time it happens, I'll try to uninstall it and see if there's a change. My CPU never went beyond 10% even when playing Crysis 3 on full details (see specs). I'm also trying to root out any malware so I'll see how that goes.

Specs: ASUS G750JX-T4179
Intel Core i7 Haswell 4700HQ (2,40 GHz)
GEFORCE 770M GTX (3GB)
16 GB RAM DDR3
SSD 64 + 750GB 7200RPM
Win 8.1
 

Fratello2466

Reputable
Oct 13, 2014
8
0
4,520
1
Hey, I use Razer too for my setup I had these problem sometimes too. I just close and reload the Synapse program and CPU usage reverts to default.
 

inf3

Reputable
Aug 27, 2015
15
0
4,510
0
This is not necessary Razer related issue. I got the same by Logitech G400 about 25-30% CPU usage when I move the pointer in circles. With a noname wireless mouse about 12%. It increases the CPU usage by explorer exe if I move the pointer over the desktop and by Firefox if the focus is on that. So it is not even application and driver related, since the noname mouse has different driver than the G400. My issue is not even OS related, I have the same phenomenon by Linux Mint too. I removed every non essential hardware and changed the USB slot, but it did not have any effect (I don't have PS/2 slot, so I did not try with that). I checked the health of every essential component: CPU, RAM, GPU, SSD, HDD, pendrive (used by installing Linux), but they appear to be okay. I did not check the PSU and the motherboard. The PSU isn't a cheap one, so that should be okay. The CPU performance dropped about 5% if I tested while moving the mouse. I changed the CPU multiplier from 8 to 6. The connection between CPU usage and multiplier change was linear, so the mouse movement always uses the same amount of counts. I think this is the normal behavior of the system. With a much better motherboard and CPU I most probably would not have this problem. So if you just discovered this problem by your mouse I think you should not worry, maybe it is not a real problem.
 

Similar threads


TRENDING THREADS