Question High end pc drops frames while streaming!

Nov 22, 2018
31
2
35
0
Hello.
Need help regarding streaming
CPU - R9 3900x
GPU - RTX 2070
RAM - 16GB G.skill trident Z 3200mhz (8GB x 2)
MOBO - ASUS ROG STRIX x570 GAMING-E WIFI

I started streaming after reading a few guides on OBS and watching a few videos of streamers on how to set it up. Read guides that OBS has on its own pages too. But, whenever I stream,(mainly pubg and apex) there is a lot of encoding lag and skipped frames even on low-medium settings! I updated the settings to use the new NVENC according to videos posted by nvidia too but its still no use! Help!
 
Kind of a waste of a good streaming CPU to use NVENC and tax your GPU while it's trying to render the graphics.

Also, what's your upload speed? You'll need at least 12Mb if you want to use the max 6000 bitrate.

There's no way you should have to use low/med settings on that spec.
 
I have a 50mbps upload speed!
Should I stream using the cpu then?
The problem is that this issue never happened before!
If it just started happening, do malware scans, and check for system file corruption.

https://www.malwarebytes.com/premium/

https://support.microsoft.com/en-us/help/4026529/windows-10-using-system-file-checker (follow instructions exactly)

If still having problems, think of any new software you may have installed since it started happening. Also try disabling any unnecessary startups.

And yes, I would try streaming off your CPU, as it will free up the GPU for just rendering the game. It's also a very good CPU for streaming. NVENC is better for older Intel CPUs.
 
Reactions: abhishek2696hhh
Nov 22, 2018
31
2
35
0
So I completepy reinstalled the OBS studio software and somehow the frame drops and encoder lag went down below 1% in most games. Weird. Also, I will try using the CPU and let you know how it holds up against NVENC! Thanks!
 
So I completepy reinstalled the OBS studio software and somehow the frame drops and encoder lag went down below 1% in most games. Weird. Also, I will try using the CPU and let you know how it holds up against NVENC! Thanks!
Sounds like something may have corrupted the OBS files. In that case the malware and system file scans mentioned above are all the more important. You didn't say if you did them, so just checking. Could have just been a bad OBS install, but you never know until you check such things.
 
Reactions: abhishek2696hhh
Yeah actually I had just installed windows like 7 days ago so i was posituve it didn't have any malwares byt just to be sure i'll run the scan and let you know!
Yeah don't forget to run the SFC scan too, and definitely paste in the command on that site I linked to restore the system image before you run the SFC scan. You also need to use CMD Prompt as Admin.

SFC works much better in W10 than in prior versions of Windows.
 

ASK THE COMMUNITY

TRENDING THREADS