Question High end PC that I built underperforming

Merrick2472

Distinguished
Sep 20, 2014
7
0
18,510
0
So last year I built this PC (check link for specs): https://pcpartpicker.com/list/3LwnZZ

A while back I had a couple of blue screens when gaming and since then performance while gaming has been poor for the components I have. For example, in CSGO even on medium/low settings I’m dipping to low 100 fps in gun fights and the it feels very ‘choppy’.

I was expecting on a game like this, with these components to be able to play 300/400 fps consistently with high settings if I wanted.

So I’m not really sure what the problem is or where to start looking. I have uninstalled/reinstalled the game and have installed the latest GPU drivers. Checking temperatures and my CPU rarely goes higher than 65C and GPU 50C in game.

looking for some answers as to what issues to test for and fix to help my system perform as it should for the sum of the components,
 

Phaaze88

Titan
Ambassador
Blue screens are probably from you losing the mixed ram lottery. The current config increases the compatibility rate, but it does not guarantee stability.
A 4x 8GB kit is already tested and certified for you.

Get enough blue screens and you may have corrupt or broken Windows drivers. Give the system file scan a go:
https://support.microsoft.com/en-us/topic/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system-files-79aa86cb-ca52-166a-92a3-966e85d4094e
Also, disable Xbox Game Bar and Game Mode.

I found the psu in C Tier on this list. You are also using cable extensions, which the added length has a consequence of additional electrical resistance; a little less rail voltage going to the parts that need it.
 
So last year I built this PC (check link for specs): https://pcpartpicker.com/list/3LwnZZ

A while back I had a couple of blue screens when gaming and since then performance while gaming has been poor for the components I have. For example, in CSGO even on medium/low settings I’m dipping to low 100 fps in gun fights and the it feels very ‘choppy’.

I was expecting on a game like this, with these components to be able to play 300/400 fps consistently with high settings if I wanted.

So I’m not really sure what the problem is or where to start looking. I have uninstalled/reinstalled the game and have installed the latest GPU drivers. Checking temperatures and my CPU rarely goes higher than 65C and GPU 50C in game.

looking for some answers as to what issues to test for and fix to help my system perform as it should for the sum of the components,
Psu.....one year warranty.....forget it.
Get a quality psu 7/10yr warranty.
 

ASK THE COMMUNITY