Hitachi 3TB external USB3 hard drive no work with NEC USB3 Version 10190


Mar 2, 2012
HI. I have a Hitachi USB3 external 3TB drive. It doesn't work with my computer ASrock extreme6 Mother board's NEC USB3 driver version10190. But it work with USB2 ports. And if I use USB3 ports for USB2 drive, It works OK. My OS is window 7 64bits. Please help!


Apr 29, 2012

Hi tsoieys.

It is not clear if you got your PC preconfigured and preloaded. If the answer is "YES" and you have a valid warranty try first with the vendor.

DIY sugeestions.
You can try to uninstall the driver for USB3 and install it again form the motherboard's software CD. Have in mind that the Win 7 OS has NO DRIVER for USB 3.0 Host Controller.

I am running the same OS with you and recently I bought a "PCI-E to USB 3.0 Internal Combo -USB 3.0 4-ports Host+USB2.0 All-in-one Card Reader" since my motherboard has no usb3 ports. To that combo I connect my two Hitachi Touro Desk Pro 3TB USB3 HDDs.
You can try what worked in my case.

Following guide lines apply to and work for Win7-64bit OS, as tested on my PC
Before anything else:
1. Uninstall whatever software you have tried to make it work.
2. In case of drivers, uninstall thru Device Manager

. . . and then,

1. Go to at the bottom of page "Host (Driver) VL800 & VL801 Superspeed USB Host Controller Driver 1.90A – Released Feb 8, 2012"
2. Download the file VL800 & VL801 USB 3.0 Host Controller Driver 1.90A
3. Unzip and run it.
4. Reboot

The USB3 ports should be automatically recognized and start working retaining the back-compatibility.
Good Luck :)