Home Networking / DHCP assignment issue

Nov 1, 2018
4
0
10
0
Hi,

I’m having issues where my DHCP is not assigning IPs on some devices on my network in the correct range.

I’ve switched the Gateway from 192.168.0.1 to 192.168.1.1.

After that, I have small subset of devices that will not get an IP address in the appropriate range. They stay within 192.168.0.x range instead of the 192.168.1.x range. Even the gateway on ipconfig reads 192.168.1.1.

I can’t figure out how to force these items on the right range. I’ve tried:
• Rebooting the router
• Rebooting the devices
• ipconfig /release and /renew

Any ideas are appreciated

Provider: Spectrum
Modem/Router: TC8717T

Thank you
 
U may have knowledge gap about tcp/ip.

Assuming typical mask of 255.255.255.0, 192.168.0.x and 192.168.1.x are TWO SEPARATE subnets and you cannot mix them. Use one or the other, PICK ONE.

The gateway MUST BE on the same subnet, and is also the IP or the router box.

Once again, pick 0.x or 1.x cannot mix both.

Once you have re-config DHCP server, u should reboot all clients.
 
Nov 1, 2018
4
0
10
0


No static IPs assigned. I've checked it from both the router and the Windows side.

As for the DHCP server, maybe? I don't have a second one that I know of but maybe there's a program installed someplace that messes with things. Any suggestions on how to hunt that down?

When I have my gateway set to 192.168.1.1, the following devices won't be assigned a correct IP:

  • Windows 10 (Wireless 2.4)
    Two Android phones (Wireless 5)
When I have my gateway set to 192.168.0.1, the following devices won't be assigned a correct IP:

  • Windows 7 (Ethernet)
    iPhone on iOS12 (Wireless 5)
    Windows 10 Laptop (Wireless 5)
 


Based on what you said this is likely the fix. Your DHCP server settings need to be updated. NAT settings and DHCP don't have to match. You can NAT more than your DHCP is assigning. I'm guessing you didn't check before downvoting.
 
Nov 1, 2018
4
0
10
0


I'm not attempting to mix them? I'm trying to get my devices on one or the other.

I've tried setting the gateway to 192.168.0.1 and I've also tried it at 192.168.1.1. The router/modem automatically sets the DHCP range to the right subnet. I can only configure last octet, which by default is 2-255

For each one I get a different set of devices failing to update.

That said, maybe there is something I'm fundamentally not understanding here. I cannot have the Gateway and DHCP setting on a different subnet. Here's a sample screenshot: https://imgur.com/a/aQUm2n1
 


Try including the gateway in the DHCP range. If it's configuring your NAT and your DHCP on the same field then you will want it in there.
 
Nov 1, 2018
4
0
10
0
I ended up doing the following:
1. Setting the DHCP lease to the shortest amount of time (2 minutes)
2. Rebooted the Wifi/Router module
3. Waited a few minutes.

That seemed to force everything back on the right settings. No idea why release/renew didn't force the change but this seemed to have done the trick
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS