[SOLVED] Hourly Disconnects

Oct 31, 2019
4
0
10
0
I am currently on a Windows 10 machine plugged into a wifi extender. Every hour on the dot I will disconnect for about 10 seconds. I think it has something to do with my DHCP lease time and idk how to fix this issue. I tried logging into my optimum router and my wifi extender, but there weren't any settings I could configure to fix the issue. I tried setting a static IP address to my machine but that caused intermittent connectivity among my other devices. When I was plugged into my router I wasn't getting this issue. Any help would be appreciated. Thanks
 
Maybe not the best solution but it should hide the problem. Most dhcp pools start at the bottom and people don't have many devices in their house.
So you can likely assign static ip out of the high end. Say your router uses 192.168.0.1 start using ip like 192.168.0.200. It is better to get them outside the dhcp pool but until you can make changes to your router this may be a bandaid.

If it keeps happening with static ip you then have a different issues.
 

kanewolf

Titan
Moderator
Your DHCP lease time is defined by your router or by the extender, but start with the router. You can see your DHCP lease by opening a cmd window and running ipconfig /all | findstr -i lease You can also run ipconfig /all | findstr -i dhcp to see the server.
That will show you the DHCP server and the duration. Your PC will renew after 1/2 the lease time. So a 2 hour lease time will renew after 1 hour.
 
Oct 31, 2019
4
0
10
0
Your DHCP lease time is defined by your router or by the extender, but start with the router. You can see your DHCP lease by opening a cmd window and running ipconfig /all | findstr -i lease You can also run ipconfig /all | findstr -i dhcp to see the server.
That will show you the DHCP server and the duration. Your PC will renew after 1/2 the lease time. So a 2 hour lease time will renew after 1 hour.
Thanks for the reply,

Ya I use ipconfig /all to check when I'm about to disconnect and the lease time is always one hour. Once hour is up, ill lose connection for about 10 seconds. When i do ipconfig /release and /renew, it will still disconnect me at the first hour lease time.
 

kanewolf

Titan
Moderator
If you use ipconfig, then you know the IP address of the DHCP server. You need to login to that device to change the duration of the DHCP lease. Or if you know what addresses WON'T conflict with the DHCP range, then you could set a static IP on your device.
 
Oct 31, 2019
4
0
10
0
If you use ipconfig, then you know the IP address of the DHCP server. You need to login to that device to change the duration of the DHCP lease. Or if you know what addresses WON'T conflict with the DHCP range, then you could set a static IP on your device.
The DHCP server IP address is the same as my default gateway, which offers no options for me to configure, because I already tried logging into my router and there was nothing I could change.

How can I find what addresses won't conflict with the dhcp range? Cause it seems like setting static IP address is my only option.
 

kanewolf

Titan
Moderator
The DHCP server IP address is the same as my default gateway, which offers no options for me to configure, because I already tried logging into my router and there was nothing I could change.

How can I find what addresses won't conflict with the dhcp range? Cause it seems like setting static IP address is my only option.
The IP range would be listed in the DHCP page of the router. What is the model of the router?
 
Maybe not the best solution but it should hide the problem. Most dhcp pools start at the bottom and people don't have many devices in their house.
So you can likely assign static ip out of the high end. Say your router uses 192.168.0.1 start using ip like 192.168.0.200. It is better to get them outside the dhcp pool but until you can make changes to your router this may be a bandaid.

If it keeps happening with static ip you then have a different issues.
 

ASK THE COMMUNITY

TRENDING THREADS