[SOLVED] How can i limit my monitor resolution?

Status
Not open for further replies.
Jan 9, 2021
4
0
20
0
The issue i'm having is that Windows is allowing me to select resolutions that are higher than the native of my monitor (1440x900).

View: https://imgur.com/a/cGNPXbd


I already tried CRU, but for some reason, it crashes my computer. So now i'm wondering, is there anything that can limit my monitor resolution?
'cause even when the monitor's driver is installed, nothing changes (it doesn't even shows the native res. as recommended)...

I have a GTX 970 with a VGA monitor, and i'm using a DVI to VGA adapter.
 
Jan 9, 2021
4
0
20
0
Since the native resolution is not marked as "recommended", every time i open a fullscreen application (a game, for example), the resolution is set to the highest available, and this causes my screen to go black because the monitor doesn't supports a res this high.
 

4745454b

Titan
Moderator
Gotcha. Would be nice if game opened at whatever res windows was set for. Win 10 i assume? Any game work?

The issue is the vga. And/or adapter. A new monitor would fix it. And by new i mean one supports dvi, hdmi, dp.
 

MJS WARLORD

Reputable
Jul 3, 2016
524
51
5,140
28
have you tried this , right click on desktop the click on display properties , click advanced display settings , then click adaptor display properties , click monitor tab and tick the box that says hide settings my monitor cant support.

Dont know if that will fix your problem but why not try it anyway
 
Jan 9, 2021
4
0
20
0
Gotcha. Would be nice if game opened at whatever res windows was set for. Win 10 i assume? Any game work?

The issue is the vga. And/or adapter. A new monitor would fix it. And by new i mean one supports dvi, hdmi, dp.
Yes i'm using Windows 10, and every game that allows me to change resolution through a cfg file, or that i can easily turn fullscreen off, works.

have you tried this , right click on desktop the click on display properties , click advanced display settings , then click adaptor display properties , click monitor tab and tick the box that says hide settings my monitor cant support.

Dont know if that will fix your problem but why not try it anyway
I tried doing that but the check box is greyed out, probably because my monitor driver isn't working for some reason...
 
Jan 9, 2021
4
0
20
0
Thanks for replying, everyone.
I managed to fix this problem by searching a value called "NV_Modes" inside the registry
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control"
and deleting all resolutions that were greater than "1440x900". It didn't removed all of them, but the ones that remained are small enough that, when selected, won't make my screen go black.
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS