How can I read files on LaCie Drive using Linux

jbeigh

Distinguished
Oct 24, 2009
16
0
18,510
I have a LaCie 2Big drive that had an enclosure failure. It was operating in "SAFE" RAID 1 mode, so I believe the data is secure and still on each of the internal drives. I was sent an advanced replacement unit and had hoped to simply plug my old drives into the new enclosure and be back up and running, but no such luck since the firmware on the new enclosure was different.

As a MAC user, I am not completely familiar with PC operating systems, but do have an Intel MacBook Pro, so I thought I would take a crack at running Linux (Ubuntu) to read one of the drives.

After MUCH pain, I was finally able to see through the system Checkbox Report the "file path" to the drive and the USB controller I am using to attach it.

When I go to its location (ctrl-L) by typing the path, i can see all sorts of Linux folders and file names, but can not find my data.

Can someone PLEASE tell me where to look? Is the data somehow hidden, or encrypted? This is too complicated for a Mac user. I don't like to think this hard...LOL
 

sub mesa

Distinguished
Depending on Ubuntu version, you can access the partition editor in System -> Administration -> Partition Editor. Could you give us the partition layout of the drive?

A screenshot would be preferable. Text output can also be done usng the terminal "fdisk -l /dev/sdX" replace the X with the name of your disk.
 

jbeigh

Distinguished
Oct 24, 2009
16
0
18,510
I can not find the Partition Editor in my version of Ubuntu.

I ran the terminal "fdisk -l /dev/sdX" but must have done something wrong. See below:

jason@jason-ubuntu:~$ fdisk -1 /dev/sdb
fdisk: invalid option -- '1'

Usage: fdisk [-b SSZ] [-u] DISK Change partition table
fdisk -l [-b SSZ] [-u] DISK List partition table(s)
fdisk -s PARTITION Give partition size(s) in blocks
fdisk -v Give fdisk version
Here DISK is something like /dev/hdb or /dev/sda
and PARTITION is something like /dev/hda7
-u: give Start and End in sector (instead of cylinder) units
-b 2048: (for certain MO disks) use 2048-byte sectors
jason@jason-ubuntu:~$


I also ran a Checkbox Report, but it is quite long, what is the best way to share it with you?
 

sub mesa

Distinguished
Its fdisk -l not fdisk -1, although i admit it looks very similar. :)

So its the underscore version of the 'L' letter, it stands for "List partition table", but linux is case-sensitive, so you have to use underscore -l:

fdisk -l /dev/sdb
 

sub mesa

Distinguished
You posted alot of data, but not the partition table layout as far as i can see. Could you post this as well? It should be text as its output in the terminal, so you don't have to paste it in here.

Also, you can install partition editor by selecting Application -> Add/Remove software, and then launch it in System->Administration-> Partition Editor. This is a graphical app like Partition Magic and can display your partitions as well.

Once i know what your disk looks like, you can try mounting it and see if you can access the data. But please give me a partition list output first.
 

sub mesa

Distinguished
Also, how did you connect the drive(s)? You said using USB, but you said you had a failure with the Lacie enclosure. Normally that means taking the disks out and connecting one of the disks directly to your computer, using Serial ATA cable.

Maybe that's not required, but please tell me how you connected your disks, are you still using the external Lacie enclosure?
 

jbeigh

Distinguished
Oct 24, 2009
16
0
18,510
Take a look at pic #1 of the images I posted.

http://www.thebeighs.com/ubuntu/ubuntu_question_site/Photos_files/Media/Picture%201/Picture%201.jpg?disposition=download

I am connected via a USB to SATA controller made by JMicron Technology Corp. Since the enclosure has failed, i can not use it to connect.

I tried to use the new enclosure they sent me with the new drive, but LaCie has made it so that newer enclosures with updated firmware can not be used to read older drives, even though they are from the exact same unit. I think that is pretty poor development. One would think they would make their firmware backward compatible.
 

sub mesa

Distinguished
What about taking the drives out of their enclosure and connecting them directly to your PC and getting the data off the disk? You want your data back right? Then you can just put them back in the new unit, reformat and put it back.

If its soft-RAID which i suspect, you may not need to take them out of the enclosure, but i'd need to see the partition layout to judge on that.

While you posted alot of data, i do not see the output of "sudo fdisk -l /dev/sdb" or a screenshot of Partition Editor, which is what i need to judge whether you can recover your data at this point or need to move the disks out of their enclosure and connect one of them internally.
 

jbeigh

Distinguished
Oct 24, 2009
16
0
18,510
I am assuming my data is on the partition at the bottom of the list (/dev/sdb2) which is is an xfs file system containing 930.55GB. I estimate that I have about 600GB used on that partition.
 

sub mesa

Distinguished
Indeed. :)

You need to install additional software to use that XFS partition.

Go to System->Administration->Synaptic Package Manager. Click Search and type "xfs" then double click the "xfsprogs" package and click the Apply button. After installation, you should be able to mount the XFS partition.

After having installed xfsprogs, try if you can access the partition the easy way:
click Places->Home folder. On the left side you should see something like "930GB media". Click on it and it should mount automatically, and you should see your files. :)
 

jbeigh

Distinguished
Oct 24, 2009
16
0
18,510
OK, everything went well up until the "...you can access the partition the easy way" part. when i click on Places->Home folder it does not show up. is there another way to access it or "map it" so that it mounts?
 

sub mesa

Distinguished
Open a terminal (Applications->Accessoires->Terminal)
enter exactly:

sudo mkdir /mnt/xfs
sudo mount -t xfs -r /dev/sdb2 /mnt/xfs

Now click the Places->Home Folder again and navigate to the root, then to the "mnt" folder, then to the "xfs" folder. Now you should see your files.

It will be mounted read-only, to avoid it changing the files. Just check if you can read it and if so you should be able to move that data via the network to other places.
 

sub mesa

Distinguished
Sorry about my late response, i had some issues with these forums.

I didn't expect that message; could you give me some further text output of the following commands?

First retype the command:
sudo mount -t xfs -r /dev/sdb2 /mnt/xfs
(it will fail with the same message thats ok)

dmesg | tail
dmesg | grep sdb
cat /var/run/dmesg.boot | grep sdb
mount

(so 4 separate commands; they all do nothing but give text output; information only they don't affect anything else)

Also, did you close all other windows/apps? Just to be safe, exit the partition manager and close all nautilus windows (nautilus = the file manager which you use to browse folders). Though that shouldn't be the problem. :)

You may indeed be close. It may also be the /dev/sdb disk is used by software RAID; linux can read RAID configuration of other brands and apply its own software RAID. With the output of the commands i gave you i should be able to figure that out.

I'll be back here tomorrow, to check on your progress. :)
 

jbeigh

Distinguished
Oct 24, 2009
16
0
18,510
jason@jason-ubuntu:~$ sudo mount -t xfs -r /dev/sdb2 /mnt/xfs
[sudo] password for jason:
mount: /dev/sdb2 already mounted or /mnt/xfs busy
jason@jason-ubuntu:~$ dmesg | tail
[11716.539192] usb 1-1: USB disconnect, address 5
[11717.348524] usb 1-1: new high speed USB device using ehci_hcd and address 6
[11718.117255] usb 1-1: configuration #1 chosen from 1 choice
[11718.221074] uvcvideo: Found UVC 1.00 device Built-in iSight (05ac:8502)
[11718.244572] input: Built-in iSight as /devices/pci0000:00/0000:00:11.0/0000:02:03.0/usb1/1-1/1-1:1.0/input/input11
[15878.765765] usb 1-1: USB disconnect, address 6
[15879.580520] usb 1-1: new high speed USB device using ehci_hcd and address 7
[15880.915419] usb 1-1: configuration #1 chosen from 1 choice
[15881.026694] uvcvideo: Found UVC 1.00 device Built-in iSight (05ac:8502)
[15881.050961] input: Built-in iSight as /devices/pci0000:00/0000:00:11.0/0000:02:03.0/usb1/1-1/1-1:1.0/input/input12
jason@jason-ubuntu:~$ dmesg | grep sdb
[ 52.520287] sd 3:0:0:0: [sdb] 1953525168 512-byte hardware sectors: (1.00 TB/931 GiB)
[ 52.522915] sd 3:0:0:0: [sdb] Write Protect is off
[ 52.522943] sd 3:0:0:0: [sdb] Mode Sense: 00 38 00 00
[ 52.523005] sd 3:0:0:0: [sdb] Assuming drive cache: write through
[ 52.530873] sd 3:0:0:0: [sdb] 1953525168 512-byte hardware sectors: (1.00 TB/931 GiB)
[ 52.533389] sd 3:0:0:0: [sdb] Write Protect is off
[ 52.533393] sd 3:0:0:0: [sdb] Mode Sense: 00 38 00 00
[ 52.533395] sd 3:0:0:0: [sdb] Assuming drive cache: write through
[ 52.533530] sdb: sdb1 < sdb5 sdb6 sdb7 sdb8 sdb9 sdb10 > sdb2
[ 52.554638] sd 3:0:0:0: [sdb] Attached SCSI disk
[ 53.448325] md: bind<sdb2>
[ 53.499541] md: bind<sdb5>
[ 53.506366] md: bind<sdb7>
[ 53.555532] md: bind<sdb8>
[ 53.561454] md: bind<sdb9>
jason@jason-ubuntu:~$ cat /var/run/dmesg.boot | grep sdb
cat: /var/run/dmesg.boot: No such file or directory
jason@jason-ubuntu:~$ mount
/dev/sda1 on / type ext3 (rw,relatime,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
lrm on /lib/modules/2.6.28-16-generic/volatile type tmpfs (rw,mode=755)
securityfs on /sys/kernel/security type securityfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/jason/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=jason)
jason@jason-ubuntu:~$
 

sub mesa

Distinguished
Ah yes, the "md" driver or Multiple Device driver is using your /dev/sdb disk as it detects that disk as being a RAID-member. To be able to mount it normally, we have to disable "md" first. md is just Linux software RAID, that is compatible with many other RAID formats so it detects your disk as being part of a RAID.

Maybe the simplest is to disable the detection of RAID errors, by adding this text to the kernel boot line:

raid=noautodetect

To do this, reboot until you see the ubuntu boot menu where its counting from 5 to 0. Press "e" to edit the boot line, you should be able to add the "raid=noautodetect" to the existing boot line.

So when you get the boot menu:
- press 'e'
- press a space
- enter "raid=noautodetect"
- press enter to boot
- open a terminal and repeat the "sudo mount -t xfs -r /dev/sdb2 /mnt/xfs" command
- check /mnt/xfs to see if you can access your files

Hope this works. :)
 

sub mesa

Distinguished
Hehe yeah i don't sleep, i feed my body through enzymes once a month so i can stay up 24/7. :)

Just kidding, in fact i have to do alot of work at night, but have spare time in between so like to be occupied, and browsing forums is one occupation i do. :)

Let me know if the raid=noautodetect option worked, allowing you to successfully mount your drive.
 

jbeigh

Distinguished
Oct 24, 2009
16
0
18,510
OK, i had to take a day off from this, so here is where I am. I tried to edit the boot line, but got some different messages when i was following the directions.

http://www.thebeighs.com/ubuntu/ubuntu_question_site/Editing_Boot_Line.html

In the first screen, I hit "e" on the highlighted selection. when i got to the next screen i was lost. Which line am i editing, or am i adding a line?

Sorry for my lack of experience in all of this Linux stuff. I have had NO experience with it before last week. I do find it intriguing though.
 

sub mesa

Distinguished
Sorry my mistake! You're using GRUB while i use a different loader, which behaves a little different.

These instructions should help you:
http://grumpymole.blogspot.com/2007/05/ubuntu-how-to-edit-grub-boot-parameters.html

copy-paste:
* Press 'e' to start editing.
* Scroll down to the "kernel..." line. The is the line that tells Grub which kernel to boot with and the parameters to be passed to the kernel when it boots are placed at the end of this line.
* Press 'e' again to edit this line.
* Move to the end of the line. You will see any existing parameters and can add other new parameters to the end.
* Parameters are separated by spaces and are mostly either a single word (e.g. nolapic), or an equation (e.g. acpi=off).
* Once you have added the parameter to the end of the line, press Enter to accept the editing.
* Then press 'b' to boot using that kernel and those parameters.


So when you scroll to the end, make sure to insert a space, and add the "raid=noautodetect" without the quotes, hit enter and hit 'b' to continue booting.

Hope it finally works now!