Question How do I change the BIOS in Win 10 from MBR to UEFI, then my hard drives from MBR to GPT?

Apr 8, 2019
2
0
10
0
I installed Win 10 PRO on an Asrock X470 Master SLI/ac, which is UEFI enabled in the system BIOS. I have 2 drives, an m.2 Samsung 970 EVO SSD (1 TB) and WD SATA 7200 (6 TB). Both drives were installed when I performed the Win 10 installation. As a result, Windows boots from my SSD, which is what I want, but also puts a system reserve section on the WD hard drive. SystemInfo is Win 10 reads Legacy for the BIOS and MBR for the drives. As a result, I can’t access more than 2 TB of storage on the WD hard drive. Please review my proposed troubleshooting steps below:

1. Reformat the WD, 6 TB hard drive.

2. Shut down the computer and disable the power supply.

3. Disconnect the WD drive from the MB, then reinstall win 10 with only the SSD connected.

4. Check SystemInfo in Win 10 to see if the SSD is UEFI enabled.

5. Reconnect the WD hard drive to MB

6. Work on converting the WD drive to GPT

Am I on the right track? Any thoughts or ideas are greatly appreciated. Thank you kindly!

Frank
 

Traditore

Honorable
Nov 5, 2013
614
52
11,240
98
What installation media are you using to install Win10? The thing is, you had booted you PC in legacy mode during installation (=boot from legacy non-UEFI device) that's why you got MBR partitioned drives. And having HDD connected have nothing to do with getting UEFI or not.

First we wanna make sure you have an installation media capable of UEFI boot, and BIOS setting appropriate to boot from UEFI device.

Then you start your PC and boot from UEFI installation media (DVD, USB). During install, you delete all partitions on SSD and HDD - this way the new partition you create will format the to GPT. Simple as that. Because it's the only way it can format your drive since you have booted in UEFI mode.


If you want, you can format your HDD into GPT after the windows installation.

Delete all partitions from it. Just right click in Disk Management and -> delete. Then right click the disk and select 'Convert to GPT Disk'.

 
There were times the windows installer refused to recognize it to initiate UEFI installation when I deleted partitions of an old install of an MBR SSD. To fix that I had to do a Diskpart Clean on the SSD in order to return it to an unitialized state.

https://www.windowscentral.com/how-clean-and-format-storage-drive-using-diskpart-windows-10

A drive is delivered from the mfr. in an uninitialized state so now it's just like brand new to start the installation with. Now I just do it as a matter of course when doing fresh installs since it always works.
 
Apr 8, 2019
2
0
10
0
Good morning,

The problem is SOLVED. The advice given worked. I had to get the actual Windows 10 Pro Image and format a boot USB for UEFI using Rufus. I noticed that the disks need to be converted to GPT first before running the install. I now have a fast, efficient, and optimized machine with the full 6 TB of data available on the SATA drive. Thank you both so much for taking time out of your busy day to lend me a hand. Take care.

Frank
 

ASK THE COMMUNITY

TRENDING THREADS