How do i control which graphics card I'm using?

TheOnlyP

Reputable
Sep 13, 2014
1
0
4,510
0
I recently bought a new laptop (Acer Aspire V3-572PG). It has both Intel mobile integrated graphics and a dedicated Nvidia Geforce GT840M 2GB graphics card. My question is do both cards work together or is it only one at a time? and if its only one at a time how do i choose which one it is?

My reason for asking this question is because when I play minecraft and press f3 it says intel HD 4400 graphics in the top right corner. This gives me the impression my dedicated graphics is not being used.

Thanks for your time.
 

hoax187

Honorable
Aug 30, 2012
76
0
10,660
15
You need to install the nVidia Control Panel and assign the card you want to a specific application

However I think applications will still show that you are using the integrated GPU because the card is connected to a frame buffer not directly to your monitor to allow both card to work seamlessly when you are not using the nvidia card to save power, but you will see a difference in performance even though the app says it's using the integrated gpu

I don't think you can solve this one, I'm having this on my laptop as well and I've tried everything but applications still show the integrated gpu

I even tried to connect an external monitor to the VGA port and still didn't show the nvidia card, if you have an HDMI monitor try to

connect it to the laptop and go to the nvidia control panel and go to the multiple monitor settings and see if the external monitor is

connected to the nvidia card because my vga monitor still shows its connected to the iGPU
 

megdatronica

Reputable
Sep 13, 2014
1
0
4,510
0


I have just arrived at this thread with the exact problem described. I've just tried this and I'm pretty sure that Minecraft is still using my integrated Intel HD 4600 rather than my Nvidia GeForce GTX 860M. I have this suspicion because when I play it I get a flickering which seems to be a problem which is particular to my integrated card. I don't know why the hell it would do choose the worse of my two cards, but I'm pretty sure that's what's happening.

EDIT: Found my solution. Seems like it IS running on the Nvidia card, but somehow the issue is because of a driver for the integrated card. God knows why. Anyway, there's a page devoted to the problem here: https://bugs.mojang.com/browse/MC-58760?focusedCommentId=167546&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-167546
 

Szymonku

Reputable
Apr 9, 2015
1
0
4,510
0
Try this:
In the NVIDIA Control Panel go to "Manage 3D settings" then "Program Settings" tab and there click "Add" button to add the "Java(TM) Platform" to the list of programs. Then pick the preferred graphics processor (your NVIDIA card).

My Minecraft is showing my NVIDIA card when I press F3 but I am not completely sure about the performance because my frame rate only jumped up from 21 to around 30.
 

nileshkk9

Reputable
Dec 25, 2015
1
0
4,510
0


Jst right click on the application u want to run by your dedicated graphic and select the option "run with graphics processor" nd select your nvidia card.. It will open the application with ur dedicated card being used...hope that helps you.



 

SJL Photo

Reputable
Feb 5, 2016
1
0
4,510
0




There is a solution, minecraft runs off javaw.exe, find that file in: program files x86/Minecraft/runtime/jre-x64/ (minecraft version) 1.8.0_25/bin = then look for javaw

assign that to your dedicated graphics.

 

Similar threads


TRENDING THREADS