Question How do I enable Spatial sound ?

Sep 14, 2019
2
0
10
0
I have Arctis 5 headphones and I noticed that while playing games or watching videos in general there is no sound that travels between the right and left ear. What I mean is that everything that I hear appears to be in the middle. This is a problem as hearing footsteps above/left/right etc. is impossible. I looked around for a while and I found no answers to my problem. I would appreciate if someone could lend me a hand on how to fix the problem. I can provide more details if necessary. Also I am nothing close to a professional with computers or such so if possible an explanation with links or words that I can get would be ideal. Thank you.
 

Dunlop0078

Polypheme
Herald
Windows 10? Just right click on the speaker icon in the taskbar, left click spartial sound, and turn on windows sonic. What motherboard do you have? Many motherboard also have virtual surround options in the audio driver software, asus ROG board would be an example.
 

ASK THE COMMUNITY

TRENDING THREADS