• Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Question How do I enable turbo boost?

Jack0123

Reputable
Jan 16, 2015
25
0
4,530
0
Hello, I have a
Ryzen 3 1200 @3.1GHz
GTX 1050 Ti stock clocked
16GB ram (2x8) @2400MHz

Motherboard is Asus Prime A320m-k

I do not see an option for turbo boost in my BIOS and my CPU does not turbo beyond the original stock speed of 3.1GHz. Please, help me.
 

Jack0123

Reputable
Jan 16, 2015
25
0
4,530
0
The 1200 may not boost to 3.4ghz on all cores, try Cinebench and run the single core test and see if it boosts to 3.4ghz.
MSI Afterburner shows all cores and their respective clock speeds. In far cry 5 CPU is at 100% but the clock speed does not go beyond 3.1GHz
 

WildCard999

Titan
Herald
No idea how to do that unfortunately...
Easiest way is to update it via internet.

https://www.asus.com/us/support/FAQ/1012815/
Go into the BIOS and start at To update the BIOS by Internet:
For network connection use DHCP.
Follow the directions and do the reboot.

Try FC5 again and let me know how it worked out for you.


After you test the game there's something else you may want to do to improve performance. Go back into the BIOS, performance manager tab and there should be an option to enable DOCP. What this does is make your memory run at the correct speed, voltage & timings. With AMD Ryzen memory speed can make a big difference in gaming and while you may not get much of a boost from 2133 to 2400 (ideal would be 3000 for that board) it still could give you a few more FPS or at least more stable FPS. Do this after updating the BIOS but I also want to make sure your boost speed is fixed as well.
 

Jack0123

Reputable
Jan 16, 2015
25
0
4,530
0
Ok this is very weird. My cpu only turbo boosts for a fraction of a second (as shown in the graph below, the spikes are the CPU turbo boosting) However this is NOT during any CPU intensive tasks but just sitting on the desktop doing nothing. And in the BIOS the option to enable DOCP is missing. The only option is to disable it (which it already is).

My BIOS has been updated to the latest v5007.

CPU via MSI Afterburner - View: https://imgur.com/H3ZFPDf

BIOS - View: https://imgur.com/ZOMJI1y
 

WildCard999

Titan
Herald
Well from the BIOS pic it looks like the memory is running at the correct 2400mhz so that's good. As for the CPU I'm not really sure what to try next. Since the thread hasn't been answered someone else may see it and provide some insight and as far as I'm aware it shouldn't be a limitation of the A320 board since it's the CPU boost and not an actual overclock. If I think of something else to try I'll let you know ASAP.
 

ASK THE COMMUNITY

TRENDING THREADS