[SOLVED] How do I fix video_dxgkrnl fatal error?

Geertt2

Distinguished
Sep 27, 2012
50
1
18,535
0
Hi, I just bought a new laptop a month ago, an Aorus 15P YD. Only recently I seem to get frequent video_dxgkrnl error a few times a day. Normally when I switch between tabs on browser or programs.

I am currently on Windows 11. Originally it was windows 10, but decided to upgrade it. I searched the problem and I have done everything such as:
1.) sfc /scannow
2.) DISM /online /Cleanup-Image / ScanHealth DISM /Online /Cleanup-Image /RestoreHealth
  1. Reinstalled latest version of Nvidia and Intel graphics drivers
  2. Updated Windows
I am also trying to see how do I set my nvidia graphics card as default in Bios but can't find an option to do so. It seems the bios for Aorus 15P YD is locked. (No idea how to unlock/mod it)

Might anyone here know how to fix this problem or are their other solutions?
 
your graphics driver is having some problem changing power states. you can go into control panel, device manager, right click the nvidia gpu and bring up properties, see if there is a power management tab. if so uncheck the option to let windows turn off this device to save power.
this should prevent the bugcheck but you will still need to fix the problem.

minidumps did not have the info to resolve the issue. you need to change the dump type to kernel and provide the kernel dump c:\windows\memory.dmp

you have a updated nvidia driver on your system. you might need a custom driver for your motherboard that is older.

https://www.gigabyte.com/Laptop/AORUS-15P--Intel-11th-Gen/support#support-faq

see if you can update the intel chipset drivers.
look for a bios update if you can find one. (did not see one on website)
 
Last edited:

Colif

Win 11 Master
Moderator
Jun 12, 2015
56,572
4,478
160,690
10,210
Laptop likely uses the Intel GPU for desktop and only uses the Nvidia card for gaming and heavy graphical work, so you probably can't enable it as default in bios

I would run DDU in safe mode and remove the intel drives and reinstall from Gigabyte website


Can you follow option one on the following link - here - and then do this step below: Small memory dumps - Have Windows Create a Small Memory Dump (Minidump) on BSOD - that creates a file in c windows/minidump after the next BSOD

  1. Open Windows File Explore
  2. Navigate to C:\Windows\Minidump
  3. Copy the mini-dump files out onto your Desktop
  4. Do not use Winzip, use the built in facility in Windows
  5. Select those files on your Desktop, right click them and choose 'Send to' - Compressed (zipped) folder
  6. Upload the zip file to the Cloud (OneDrive, DropBox . . . etc.)
  7. Then post a link here to the zip file, so we can take a look for you . . .
 

Geertt2

Distinguished
Sep 27, 2012
50
1
18,535
0
Hey, thanks for taking the time out to help me with this problem. I have this link with my minidumps here:
https://drive.google.com/file/d/1V-ILzCDM5nqL5WrP1n0z5G9g-hNmJrhm/view?usp=sharing

I tried to do everything possible to fix this problem myself in the last 3 days. Besides my initial post, today I also clean installed windows from my old windows 11 back to the original windows 10 that the laptop came with. Clean installed with ddu both nvidia and intel graphics drivers multiple times. Also tried disabling fastboot in control panels... nothing seem to work.
 

Geertt2

Distinguished
Sep 27, 2012
50
1
18,535
0
your graphics driver is having some problem changing power states. you can go into control panel, device manager, right click the nvidia gpu and bring up properties, see if there is a power management tab. if so uncheck the option to let windows turn off this device to save power.
this should prevent the bugcheck but you will still need to fix the problem.

minidumps did not have the info to resolve the issue. you need to change the dump type to kernel and provide the kernel dump c:\windows\memory.dmp

you have a updated nvidia driver on your system. you might need a custom driver for your motherboard that is older.

https://www.gigabyte.com/Laptop/AORUS-15P--Intel-11th-Gen/support#support-faq

see if you can update the intel chipset drivers.
look for a bios update if you can find one. (did not see one on website)
I got the kernel dump here
https://drive.google.com/file/d/1jEfwCO41NH3uazEYPhw24Z82WOqAtIrO/view?usp=sharing
I updated the intel Serial, Chipset and management.

Having problems with the device manager, in the GPU driver properties, there isn't a power management tab.
I searched for how to get it and went into regedit to add a CsEnabled and then restarted my computer, but it still doesn't show.

Also my "intel" integrated graphics have this event:
Device PCI\VEN_8086&DEV_9A60&SUBSYS_76D11458&REV_01\3&11583659&0&10 requires further installation.

My Nvidia graphics have this event:
Device PCI\VEN_10DE&DEV_249C&SUBSYS_76D11458&REV_A1\4&721ce3b&0&0008 requires further installation.
 
Last edited:

Geertt2

Distinguished
Sep 27, 2012
50
1
18,535
0
I don't know where exactly the problem was, but it seems that after I clean re-installed windows 10, then clean re-installed intel/nvidia drivers the problem with the video_dxgkrnl_fatal_error seems to went away. Thanks all for the help.
 

ASK THE COMMUNITY

TRENDING THREADS