How do I know if I have enough power?

sixstring88

Distinguished
Jun 24, 2010
114
0
18,680
I upgraded not too long ago to an XFX Radeon HD 6790 and it wound up using 2 pci-e power connectors where my old card used one. The performance has not been where it should so I am starting to wonder if I have enough power. My PSU is an OCZ ModXStream pro 700W. I have listed my full specs below.

MSI 870A-G54 Motherboard (not the FX one)
4 GB of Corsair XMS3 DDR3 RAM 9-9-9-24
OCZ ModXStream Pro 700w PSU
AMD Athlon II 635 Propus 2.9GHz
AMD Radeon HD 6790 (dual fan)
Asus DVD rom drive
2 500GB Seagate Barracuda 7200 rpm hard drives
1 80GB Seagate Barracuda 7200 rpm hard drive
5 case fans (with blue leds except one)
Asus PCE-N10 wireless card
Zalman CNPS 7500 Cu LED cpu fan
Windows 7 Ultimate (dunno if that matters)
and I have an 360 controller, webcam, microphone, mouse and keyboard and a few usb cable for things plugged into it.
 
How do I know if I have enough power?

Stopping by here was a good idea.

That OCZ ModXStream Pro 700W should be getting plenty of power to your system.

In what way has 'performance has not been where it should'?

How has the performance changed with the graphics card swap? Any other changes made?

What card did you replace?


 

Agree with that result!
Some calculators like ASUS and Newegg really exaggerate the power need (legal issue, probably because of so many crap PSU's on the market that do not deliver the promised output)
 

sixstring88

Distinguished
Jun 24, 2010
114
0
18,680
I just went to prime 95 and clicked test and went to see if it was actually running anything and the sound started skipping and I got these white static looking lines on the screen then the blue screen of death and a restart :-/
 

sixstring88

Distinguished
Jun 24, 2010
114
0
18,680
Well I found out it was overclocked apparently by my mobo with the OC Genie feature. I ran Unigine Heaven on it earlier by the way and it didn't do horrible performance wise, however certain buildings or in some cases everything in some scenes would disappear every once in a while or kinda flicker. Does anyone know what that could mean?