Question How do i make Windows Task Manager start at start up?

TheFlash1300

Proper
Mar 15, 2022
312
7
195
2
When i start the computer, i have to press Ctrl + Shift + Esc to open Windows Task Manager. Is there a way to make Windows Task Manager open automatically once the computer is turned on and the desktop is loaded?
 

little_me

Distinguished
you could either run it as scheduled task or... add shortcut to startup folder for it?
so put a shortcut to
%windir%\system32\taskmgr.exe
into
%username%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
 

TheFlash1300

Proper
Mar 15, 2022
312
7
195
2
you could either run it as scheduled task or... add shortcut to startup folder for it?
so put a shortcut to
%windir%\system32\taskmgr.exe
into
%username%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
It didn't work.
I created a shortcut of "taskmgr.exe " in the Startup folder, but it didn't work.
 

little_me

Distinguished
On testing it with restart and logoff/logon, you are correct, shortcut does not work. it will work if you run it yourself though.

after testing it through task scheduler, I found the problem, it needs higher privileges to be run, which is possible with task scheduler and will work that way.

-Open task scheduler (type task scheduler in windows search bar)
-create basic task on actions bar on right.
-give task a name, like "Run taskmanager" and hit next
-select trigger to be "when I log on" and hit next
-select start a program and hit next
-put "c:\windows\system32\taskmgr.exe" on program/script
-put c:\windows\system32 into start in slot
-hit next
-check the open properties after I click finish and hit finish to open the properties of said task.
OR
just hit finish and open tasks properties yourself, your choice.
on first general tab, check the "run with highest privileges" checkbox
Go to settings tab
-possibly remove the checkbox on terminating task if it runs longer than 3 days if you keep your computer on 24/7 to prevent task manager from auto-closing

and THAT should work. works for me at least.
 

geofelt

Titan
I also like to have task manager open while running.
While I think there will be a way to do this, I think the better solution is to avoid startups in the first place.
Use sleep to ram(no hibernate) instead.
Sleep/wake becomes only a handful of seconds
 

little_me

Distinguished
Test this.

Create a shortcut to........%windir%\system32\taskmgr.exe /7

I think it needs to be run as admin.
While you are technically correct (it is the default way to run task manager), it will not work as startup folder run thing.
Not even run as admin thing. If you run the shortcut from there yourself after logging in, it works.
Some things need higher privileges to be run though than what said folder has permissions to run, which is why it will not work from there (unlike what I said in my 1st post, I did not log off/back on to test)

somehow startup folder starts lack permissions to be run as admin, which I found when I tried and got it to work through task scheduler. (it complained about lacking privileges, for which task scheduler had extra tick box for, after which it worked)

long story short, I have no idea why OP wants task manager to open on login but... it is not my place to question tastes.
I have it put as sticky next to start menu (and use CTRL-SHIFT-ESC half the time anyway)
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
60,248
5,048
166,290
10,413
somehow startup folder starts lack permissions to be run as admin
That could be a security measure. I expect lots of things would like to run as admin at start from there. Most AV use scheduled tasks instead.

here is another way to achieve elevation - https://www.tenforums.com/tutorials/57690-create-elevated-shortcut-without-uac-prompt-windows-10-a.html - its similar to yours.
its a common question - https://answers.microsoft.com/en-us/windows/forum/all/is-it-possible-to-have-taskmanager-autostart-when/a8a56901-e91a-43fe-b6bd-0068d5a84377?page=1
 

ASK THE COMMUNITY