[SOLVED] How do i properly connect a subwoofer to a pc?

May 31, 2019
2
0
20
1
I'm new to speaker stuffs and i have this Jamo sub 200 subwoofer. I connected it to my pc using an RCA (yellow, white & red) to 3.5mm jack to my motherboard's C/Sub (The orange one) to add bass to my audio since i'm only using a stereo 2.0 speakers. The problem is that the center channel plays in the LFE channel . Although it somehow works, i'm not really sure if its utilizing the subwoofer.

I've set it up as a 5.1 speaker since there are no 2.1 option in the audio configuration. If i uncheck "center" on the optional speaker section of Realtek Audio Manager it would not work at all. So now i'm stuck with this center and LFE channel playing at same time in the woofer.

And one more thing, somehow the subwoofer only works when watching movies on VLC. Playing music or watching youtube videos the woofer just wont work.


Anyone knows how to fix this?
 
Last edited:
i'm not really sure if its utilizing the subwoofer.
Modern PC audio should have a test u can run and send signal to each speakers one at a time so u can tell.

If sub plays center signal that means that cable is wired wrong. sub/c cable is a 2-channel cable, u maybe using the wrong wire to power the sub. I don't know what else to tell you wo knowing how the rest of the speakers are hooked up, u seems to be only interested in the sub.
 
May 31, 2019
2
0
20
1
Okay, after messing around for a few hours i finally found the solution. So basically when configuring the speakers there is an option called Full-range Speakers, just disable or uncheck it and enable Swap center / subwoofer ouput in the enhancement tab.
 
Jun 3, 2019
15
0
10
0
wish i saw this earlier, i remember pulling my hair out, hearing the sub barely on, then found out about the large speaker setting out of sheer brute forcing the menu haha. I set mine to small all around and enabled sub specifically
 

ASK THE COMMUNITY