How do I reinstall stock Integrated Graphics Drivers? / AMD not working well with Unity3D Games?

Jun 10, 2018
2
0
10
0
Motherboard - A320M-S2H
Processor - AMD Ryzen 5 2400g
GPU - Integrated Radeon Vega 11
RAM - 8GB

So I bought this PC a couple of months ago, and used it for some schoolwork and gaming.

I didn't install anything other than the Windows 10 OS because the PC didn't come with an pre-installed OS.

One of the first games I installed on this was Subnautica. At first it ran well enough with a decent enough frame rate which was good.

Finished the game, enjoyed it, blah blah.

Decided to upgrade my drivers to Adrenalin 18.5.1.

Tried relaunching Subnautica and the only thing that greeted me was a the date and the loading bar, and it immediately crashes.

Tried updating drivers and installing new Windows Updates and such, downloaded DirectX updates and tried all versions yet still nothing.

Went to Device Manager as well but found that I couldn't roll back my GPU drivers for some reason.

Tried downloading Raft as well, but alas, it also doesn't work.
Realized that both these games ran on Unity3D, so I'll really appreciate it if someone would show me the way to reinstall STOCK GPU Drivers or atleast a fix on Unity3D problems

 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS

Latest posts