How do i remove the disk write protection from my micro sd card? (I've tried everything! )


Feb 24, 2013
Actually there should be a tiny switch on the top left side when its in one position is considered "lock" and read only. In the other position is should be "unlocked" and be writeable. I believe this applies to most regular sized sd cards. Let me know if it works


Aug 17, 2017
I went about this in a roundabout way so not sure what did it

(The 1st part may not be necessary)

but I was in same sich & fixed it

(((((((1st part :
I went to regedit
Did the known modifications adding the value to
plus these:
took a backup
Erased all entries under
inserted my sd
noticed the new entry
Restored Registry
went ahead and added a Dword value for WriteProtect to that entry (value=0)
Then i went here
and checked out the values of Dwords within
There were these values for the dwords of different entries, 1 per entry 16, 32, 32, 128, 256
my sd was 64gb and was incorrectly identified as 32gb by windows.
so I changed one of the 32s to 64
And added a WriteProtect and a ReadOnly Dword value for good luck
tried format.... it froze)))))))

2nd part:

tried Yumi
it worked

the answer may be as simple as using yumi program
I am not sure

I have come to this site for help before and it usually solves whatever sh#% I might find myself stuck in from poweruser level day to day MS and linux usage
and I know you guys who are either regulars or are Mods here can solve it and edit this answer.
I hope you get some of of your SD cards back for doing it
I know many people will certainly get theirs back if you follow this up.

P.s. Another solution I read once was to insert it into a portable camera which uses micro SD cards and let it format it for you.

I got so far as to find a rough description the protocols used (but they seemed proprietary)
I could not find what voltages to apply to which pins to throw it back in its default state of all ones.
But it looked as if there was a simple solution going down that route as well.

could not find the voltage scheme for that

Mine was 64gb.
Not as cheap it was handy.

Thanks, tomshardware, for your great solutions/hacks.

Philip S. Bodenheimer