How do I run DX9 on a DX10 card in Vista?

eqselgonas

Distinguished
Jun 29, 2007
20
0
18,510
0
So after I upgraded my video card to a Radeon HD 3870, one of my games will not run. I get the message "Ultimate Spider-Man has stopped working" after double-clicking the game icon. Just to be sure I popped by old DX9 card back into my system and the game fires right up.

So before I throw in the towel, thought I ask f there was an option or setting I could try to get the game to run with my new card. I run Vista 64-bit.

Thanks in advance. :ange:
 

Hellboy

Distinguished
Jun 1, 2007
1,842
0
19,810
18
Sounds like the drivers need more attention to me....

Welcome to the world of 64 bit and AMDs crappy drivers...

Good Luck

Out of curiosity what was your old card...................
 

eqselgonas

Distinguished
Jun 29, 2007
20
0
18,510
0
I had a slim hope there was an option, but my expectation is that older games will have issues with Vista. This game is for my son, who likes to swing around the city as Spider-Man. So I ordered Spider-Man 3 the game figuring it should be okay since it was made in 2007.

On Activisions support site, they state for Ultimate Spider-Man:

"This product is designed for use with Microsoft Windows 2000/XP and Activision cannot guarantee full compatibility with Windows Vista. This product has not been thoroughly tested and certified with the new Microsoft Operating System."

My old card was the X1950PRO.
 

mweidler

Distinguished
Dec 22, 2007
219
0
18,680
0
have you tried to run the game in 32 bit emulation. right click on the shortcut and you should see a checkbox for it. if that doesnt work make sure you have all the hotfixes installed. go to vistax64.com and look in the gaming section
 

ASK THE COMMUNITY

TRENDING THREADS