[SOLVED] How to check if I updated chipset drivers or not

SoulOfDerp

Reputable
Jun 7, 2017
89
1
4,535
0
I am using

Gigabyte GA-AB350M-Gaming 3 AM4 M.ATX

and

AMD RYZEN R7 1700 3.7GHz 16M L3 8 Core 16 Thread 65W AM4

And I want to update the chipset driver but I am not sure how or if I already did it.

I downloaded the AMD chipset driver from https://www.gigabyte.com/Motherboard/GA-AB350M-Gaming-3-rev-1x/support#support-dl-driver-chipset, ran it, dont know what it does (it just a loading bar) and it randomly restart the PC without warning. I dont even know if its updated or where I can check it.

I checked device manager but theres like 30 options under system devices and all the AMD options doesnt show the driver version matching the link above (2‎.07.21.306). How can I know if I updated the chipset driver or not or how do I check, exactly, the version numbers? I googled but all they said is to go to device manager which is no help. There's too many options there.
 

SoulOfDerp

Reputable
Jun 7, 2017
89
1
4,535
0
download and run Driverview - http://www.nirsoft.net/utils/driverview.html

All it does is looks at drivers installed; it won't install any

When you run it, go into view tab and set it to hide all Microsoft drivers, will make list shorter.

if you lucky you will find the driver version there

Which one is the correct chipset driver anyway? This is from the MB https://www.gigabyte.com/Motherboard/GA-AB350M-Gaming-3-rev-1x/support#support-dl-driver-chipset

However in the AMD site there's another one with different version? https://www.amd.com/en/support/chipsets/amd-socket-am4/b350
 

Colif

Win 10 Master
Moderator
well, the one on gigabyte website was released in August and is version 2‎.07.21.306 whereas the AMD driver was released in October and is version 2.10.13.408

looking at the gigabyte version number in google just brings back more gigabyte links, so it might be an oem package of amd drivers.

They are both right, the amd ones are just newer. I expect Gigabyte will release their updates at some stage.

You can't go wrong with the amd drivers as both packages are their drivers anyway... in other words, get the newer ones.
 

SoulOfDerp

Reputable
Jun 7, 2017
89
1
4,535
0
well, the one on gigabyte website was released in August and is version 2‎.07.21.306 whereas the AMD driver was released in October and is version 2.10.13.408

looking at the gigabyte version number in google just brings back more gigabyte links, so it might be an oem package of amd drivers.

They are both right, the amd ones are just newer. I expect Gigabyte will release their updates at some stage.

You can't go wrong with the amd drivers as both packages are their drivers anyway... in other words, get the newer ones.
Actually I am not entirely sure about the AMD one because I just choose b350 but the MB is ab350m.
 

logainofhades

Titan
Moderator
The manufacturer of specific chipset, or GPU, will always have the driver before the board partners do. I would always go to AMD for AMD related drivers, Nvidia for Nvida drivers, and Intel for Intel drivers, to make sure you are getting the latest version. I only go to board partner websites for bios updates, or special utilities that are specific to said board.
 

SoulOfDerp

Reputable
Jun 7, 2017
89
1
4,535
0
motherboard website -
Chipset - AMD B350

they are likely okay, only difference is 2 months. Gigabyte might eventually catch up.
I installed the AMD version but in driver view I cannot find the version number (2.10.13.408 ) in fact not even the 2‎.07.21.306 I installed earlier.
 

Colif

Win 10 Master
Moderator
can you take a screenshot from (and including)Driver name to (and including)Creation date.

upload it to an image sharing website and show link here. I will see what I can find.

Its 5.30am here so i have to go soon
 

SoulOfDerp

Reputable
Jun 7, 2017
89
1
4,535
0
can you take a screenshot from (and including)Driver name to (and including)Creation date.

upload it to an image sharing website and show link here. I will see what I can find.

Its 5.30am here so i have to go soon





Well, I can find some of them but not the others in the release note? Am I fine to assume its fully updated?
 

Colif

Win 10 Master
Moderator
If you can find most of them then I have to assume it worked. I don't know why all didn't work, there might be a valid reason that only AMD & Gigabyte know.

I did find I am using June ones via this search and might update mine later on some time... pc works so why mess with it?
 

SoulOfDerp

Reputable
Jun 7, 2017
89
1
4,535
0
If you can find most of them then I have to assume it worked. I don't know why all didn't work, there might be a valid reason that only AMD & Gigabyte know.

I did find I am using June ones via this search and might update mine later on some time... pc works so why mess with it?
I am the guy who had BSOD problem few months ago and it was fixed by disabling fast start up, but now it happens again without BSOD, screen just go dark and then nothing, or it auto restarts. Sometimes the screen gone black but I can still hear the youtube vid I am watching before it restarts/gone dark. Sometimes the sound stutters as the PC lags without going dark, and then restart. Again, only happens with cold boot while I can let the PC run for days perfectly without problem or after warm restarts.
 

Colif

Win 10 Master
Moderator
when it goes black, does it show any errors in reliability monitor at the same time?
another place to look would be event viewer

nice if you could use that app screen to update the drivers
 

SoulOfDerp

Reputable
Jun 7, 2017
89
1
4,535
0
when it goes black, does it show any errors in reliability monitor at the same time?
another place to look would be event viewer

nice if you could use that app screen to update the drivers
I havent turn off the PC for 2 weeks now so the record seems to be partly gone in reliability monitor. However in the problem report there's these:


Others problems are mostly my game crashes.



I am not sure if I want to turn off my PC to test because there's a good chance it doesnt even boot (like no BIOS, nothing, monitor light stays orange instead of blue like it never gets the signal).

Where should I look for in event viewer? I am not sure the exact time windows did crashed.
 

Colif

Win 10 Master
Moderator
I havent turn off the PC for 2 weeks now so the record seems to be partly gone in reliability monitor. However in the problem report there's these:
the cbs package servicing failures are all windows update
Windows\wcpOtherFailure3 is the windows module installer

see if this helps
right click start button
choose powershell (admin)
type SFC /scannow and press enter
once its completed, copy/paste this command into same window:

Repair-WindowsImage -Online -RestoreHealth
and press enter


SFC fixes system files, second command cleans the windows image files( win 10 has a copy of all the files needed to reinstall itself), re run SFC if it failed to fix all files. helps to restart PC after but then there is

I am not sure if I want to turn off my PC to test because there's a good chance it doesnt even boot (like no BIOS, nothing, monitor light stays orange instead of blue like it never gets the signal).
which isn't exactly normal.

what are all the parts in the PC?
 

SoulOfDerp

Reputable
Jun 7, 2017
89
1
4,535
0
the cbs package servicing failures are all windows update
Windows\wcpOtherFailure3 is the windows module installer

see if this helps
right click start button
choose powershell (admin)
type SFC /scannow and press enter
once its completed, copy/paste this command into same window:

Repair-WindowsImage -Online -RestoreHealth
and press enter


SFC fixes system files, second command cleans the windows image files( win 10 has a copy of all the files needed to reinstall itself), re run SFC if it failed to fix all files. helps to restart PC after but then there is


which isn't exactly normal.

what are all the parts in the PC?
WD Blue WD10EZEX 1TB 7200rpm 64MB 3.5 Inch HDD
Samsung 960 EVO Series - 250GB PCIe NVMe - M.2 SSD
Antec NeoEco II Series NEO-ECO2-550 80Plus Bronze 550W PSU
MSI GeForce® GTX 1070 GAMING X 8GB GDDR5
Corsair VENGEANCE® LED 16GB (2 x 8GB) DDR4 3000MHz C15 - White LED
AMD RYZEN R7 1700 3.7GHz 16M L3 8 Core 16 Thread 65W AM4
Gigabyte GA-AB350M-Gaming 3 AM4 M.ATX
WIN10

The PC is just having all kinds of problem on cold boot, not sure if its one problem or multiple.




PS C:\WINDOWS\system32> SFC /scannow

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection did not find any integrity violations.
PS C:\WINDOWS\system32> Repair-WindowsImage -Online -RestoreHealth


Path :
Online : True
ImageHealthState : Healthy
RestartNeeded : False


Seems to have nothing wrong here.
 

SoulOfDerp

Reputable
Jun 7, 2017
89
1
4,535
0
can you run this for me, it creates a zip file so if you can upload it to a file sharing website I see if it can help - https://www.sysnative.com/forums/pages/bsodcollectionapp/

how old is system? PSU seems okay, from the reviews I found for it.

if monitor stays off you can't really tell if its getting bios or not. Do you get any signs of life at all?
System is around 3 years, monitor did not stay off, it just doesnt get signal, try again later or messing around with some wires inside the case sometimes make it boot, and it never have a "not booting" problem after it does boot. Then comes the random restart/windows crash. If it get pass that or after the auto restart, it doesnt seems to have any problem at all.
 

SoulOfDerp

Reputable
Jun 7, 2017
89
1
4,535
0
might want to get it looked at by a repair shop, see if they can work out the boot thing. shouldn't need to mess around with cables.
Local repair shops are kind of terrible... they always say "you need to reinstall windows" or "I can boot it up, no problem" and still charge the investigation fee.... they never find the problems unless its literally hardware dying which I can also find with stuff like memetest(which I did too in this and nothing is wrong).

The annoying thing is that it doesnt always happen, it only happen sometimes, so my self test becomes a lot harder and local repairmans dont bother....
 
Last edited:

ASK THE COMMUNITY