Question How to check if RAM is faulty?

Aug 23, 2019
11
0
10
0
Hello, recently upgraded RAM to 32GB(4x 8GB) G.Skill Trident Z 4133 but having trouble running it at higher than 3200 so far.
I bought the RAM second hand so I'm wondering if it might be faulty.

What would be the best way to check if the RAM is faulty or it's the compatibility issue with my CPU and motherboard?
If the RAM is 100% stable at 3200, does it mean that it's definitely not faulty? or it could still be faulty at higher speed?

So far it ran ~15mins of Prime95(Large FFTs) test without any error at 3200 14-15-15-35 1T @ 1.40v (long story but thought I was running 3600 and that's why I used 1.40v instead of 1.35v)

I would just upgrade my motherboard if there's 100% guarantee that RAM would simply run fine at XMP settings but doesn't look like that's the case, and I guess there's always chance that RAM could be bit faulty so I want to find that out first.

Any advice would be much appreciated.
 
Aug 23, 2019
11
0
10
0
Thank you very much for the prompt reply.

So I just the run the memtest86(I presume you have restart PC and boot from USB) with any memory setting in BIOS?
 
Aug 23, 2019
11
0
10
0
Cool thanks again PC Tailor, never used memtest86 before so I wanted to confirm. :)

Ran the default memtest86 for ~1 hour and 45mins and it looks ok?
Result screenshot1 = View: https://imgur.com/a/F7qFZDJ

Result screenshot2 = View: https://imgur.com/a/HwEM9jg

Test screenshot1 = View: https://imgur.com/a/kgssCYD

Test screenshot2 = View: https://imgur.com/a/QI8ccou


*Note: I was gonna do the memtest86 with RAM set to default SPD setting(2133 15-15-15-36 @ 1.20v) by setting the BIOS to default with XMP disabled.
But for some reason(maybe I forgot to change?) it appears XMP was enabled with RAM set to 3600, because my memory was set to 3600 19-19-19-39 @ 1.40v when I restarted the PC just after running the memtest86. = View: https://imgur.com/a/NKNqntz
(also I'm not sure why RAM is set to 1.40v instead of 1.35v even if XMP was enabled with RAM set to 3600)

Would this make any difference on memtest86 result?
  • i.e. does this mean memtest86 test was done with my RAM set to 3600 CL19 @ 1.40v?
  • should I run the memtest86 with RAM set to 2133 CL15 @ 1.20v?
  • do you think my RAM is def not faulty?
Thank you advance.

p.s. guess I'll try to run memtest86 again, and this time I'll make sure RAM is running at stock SPD(2133 CL15 1.20v) first.
 
Last edited:
Aug 23, 2019
11
0
10
0
Ok.. ran the memtest86 again, this time made sure that RAM was running at stock SPD(2133 15-15-15-36 1.20v), and also confirmed that RAM is set to stock SPD just after the memtest86.
Looks like memtest86 ran for 2 hours and 40mins without any error.
Result screenshot1 = View: https://imgur.com/a/CwRJEgB

Result screenshot2 = View: https://imgur.com/a/8JCSA70

Test screenshot1 = View: https://imgur.com/a/QtpEJjX

(looks like completed 13 tests in 2h40m this time, and also 13 tests completed but in 1h45m the first time)

Anyway, does this mean my RAM is 100% not faulty?
Or could it still be faulty at rated speed? i.e. 4133 19-19-19-39 1.35v
(but I can't run memtest86 at 4133 since I have trouble booting at any speed above 3600.. ><)
 

PC Tailor

Dignified
Herald
It NEVER means the RAM is 100% not faulty. There is no software solution that could ever really guarantee that any piece of hardware is not faulty, however it's a very strong indicator. Usually if RAM is faulty, memtest will find it, but I've also had RAM modules pass memtest and still turn out to be faulty, just a not so obvious fault.

Only 100% guaranteed way of knowing any piece of hardware is absolutely not faulty is to replace it and see if your issue disappears.

It could well be that the RAM is faulting at the highers speeds, it could equally be the CPU or MB not handling it, higher RAM speeds can be tricky, are you enabling XMP or manually overclocking? If the former, try manual, sometimes XMP can be too generous or not generous enough voltages for example.
 
Reactions: Gintama69
Aug 23, 2019
11
0
10
0
Thank you again for the advice PC Tailor.

I simply thought if RAM passed memtest86 at SPD setting meant RAM isn't faulty.
But guess I was totally wrong, and it only means RAM is 99+% not faulty but only at SPD setting.
So in order to check RAM is 99+% not faulty, I'll actually need to pass memtest86 at XMP setting, correct?
(unfortunately I can't even boot with XMP enabled)

I might try to get my friend to test the RAM on his machine(he's also got 9900K and slightly better Gigabyte Z390 mobo) later if possible.

I think RAM is ~3 years old, and I think previous owner pushed it to the limit cos he told me that he was able to run the RAM at 4000 CL15 1.45v on X299 and 4400 CL18 1.45v on Asus Strix Z390(?) mobo with 9700K.

I tried manual setting in BIOS, enabled XMP then reduce RAM speed to 3200, 3600, 3800, 4000 but 3800 seem to get error and won't boot at 4000.
So I tried 3600 with faster timing and I was able to run 3600 14-15-15-35 1.40v stable. (or at least I thought, because later I found out that RAM was actually running at 3200 14-15-15-35 1.40v even tho it was set to 3600 in BIOS).

I might try running 3800 again, since I haven't tried 3800 with 1.40v or slower timing. Because I simply thought above 3600 was unstable on my CPU, Mobo, RAM combo.
But if I can run 3800 with slower than XMP timing with higher voltage etc then I guess that would prove that there is something wrong with the RAM.
 

ASK THE COMMUNITY

TRENDING THREADS