Question How to completely disable USB controller on an ASUS board?

Apr 2, 2021
4
0
10
0
I have an ASUS PRIME Z270-P with a fried built-in USB 3.0 controller. The fried controller prevents the computer from powering off properly from Windows (display goes off, but the power LED remains on).

Is there some way to completely disable this controller, so that it doesn't appear in the device manager at all?

I've disabled the device in the Device Manager, but it's still listed, and the problems with poweroff and sleep remain. Theres' no option to turn it off in the BIOS (at least none that look like it). Before the controller got fried both poweroff and sleep worked fine (after some BIOS and Windows tuning).

Is this possible? Thanks.
 

Ds_Tech

Great
Jan 25, 2021
185
13
95
2
There's a option in bios in advance section -> usb configuration.
in which you can disable individual usb slots check user manual also.

USB single port control The subitems in this menu allow you to set the USB Port Disable Override features.
USB3_1~8 [Enabled]Allows you to enable or disable the USB3.0 ports individually.
Configuration options: [Disabled] [Enabled]
USB9~14 [Enabled]Allows you to enable or disable the USB2.0 ports individually.
Configuration options: [Disabled] [Enabled]
 
Apr 2, 2021
4
0
10
0
May I ask why do you know that it's the USB controller is fried?
Because none of the USB ports work now, even in BIOS. Everything else, except power management, is fine. I had replaced another motherboard that had fried ports, and apparently the replacement got its controller fried after two weeks as well. I suspect the front USB ports.
P.S. The controller is listed as "Device could not start, Code 10" when enabled.
P.P.S. I had tried all sorts of BIOS resetting, including removing the battery for several days. The only thing I didn't try was completely re-flashing the BIOS with the same (latest) version.
 
Last edited:
Apr 2, 2021
4
0
10
0
There's a option in bios in advance section -> usb configuration.
in which you can disable individual usb slots check user manual also.

USB single port control The subitems in this menu allow you to set the USB Port Disable Override features.
USB3_1~8 [Enabled]Allows you to enable or disable the USB3.0 ports individually.
Configuration options: [Disabled] [Enabled]
USB9~14 [Enabled]Allows you to enable or disable the USB2.0 ports individually.
Configuration options: [Disabled] [Enabled]
Yes, thanks, I had tried those, but this apparently had no effect on the controller visibility. It was still visible in the Device Manager, and power-off and sleep didn't work, unfortunately.
 

Ds_Tech

Great
Jan 25, 2021
185
13
95
2
Try disable usb xhci hand shake.
and the option I have mentioned above will disable usb slots individually.
try disable all usb slots.
or disable usb completely from Bios and buy pci usb.
or New motherboard.
 

ASK THE COMMUNITY