How to disable auto-brightness

yonef

Distinguished
Jan 22, 2008
289
0
18,780
Is there any efficient way to get rid of the "auto-brightness" feature?
I'm not sure if this is a Graphic Card feature or monitor feature, or windows feature, but my Monitor is LG M228WA, and video: HD 4870, and this happens to Windows Vista and Windows 7 as well;

The problem is that, when dark scenes displayed, my picture goes even darker, when bright scenes displayed, my picture goes brighter.
So how can I get rid of it?
 

uncfan_2563

Distinguished
Apr 8, 2009
904
0
19,010
well, i've never heard of anything like this on a graphics card so it's probably your monitor. You can try:

1. Sifting through the monitor menus for something that could be triggering this
2. Try another monitor/tv and see if it continues
 
As uncfan mentioned, there may be some settings - like those mentioned on page 34 of your manual - that may have some affect on what you are seeing.

Other than that, I can't think of anything PC-side that would do that.
 

boudy

Distinguished
Mar 13, 2009
498
0
18,790
Looked at the features for your monitor on LG's website and found this:
FLATRON f Engine
The LG Flatron f-Engine™ uses DAFI technology and Real Colour Management (RCM) to
display colours that are vivid and natural, while Adaptive Colour Technology and Contrast
Enhancement boost brightness and contrast.
This picture-enhancing chip optimises the
image quality of videos and high-resolution digital photos.
Sound like this is your monitor.
I'm sure that your monitor has quite a few option that adjust the image quality and/or brightness automatically. Try messing around with those.

EDIT: After looking at the manual, try the settings on page 28.
 

yonef

Distinguished
Jan 22, 2008
289
0
18,780
Ok, I tried another monitor and it is not doing this; so definitelly monitor switches the brightness.

@ Twoboxer: I've tried all combinations of settinngs that are mentioned on pg.34 of the manual, one of these options changes the color temp. and the another changes preset contrast/brightness settings, but no matter what preset I choose it still goes darker in dark scenes. Strangely it is not doing that when in TV mode (the monitor has inbuild tuner). It apears to be DVI/VGA input only "feature", and yes I have tried with DVI and VGA cable to connect it to the PC.

@ boudy

do you mean this settings? Because it is not applicable to DVI.
 

boudy

Distinguished
Mar 13, 2009
498
0
18,790


No, that isn't what I meant...
I found the manual for your monitor online ( http://www.maadiran.com/Persian/Products/Monitor/UserManual/Monitor_M228WA_UserManual.pdf ), and on page 28 of that, it has a few features that you can change.

Here this is what i'm talking about:
 

yonef

Distinguished
Jan 22, 2008
289
0
18,780
OK, I found a secret menu for this monitor while googleing around. It's activated by holding both menu buttons (one on the monitor, one on the remote control) The problem is that there is no manual for this, and most of the options that I can set is just labeled "option1, option2..." :D no chance to figure out what I'm doing, but I do not want to screw somthing out.
Will be nice if there is someking of manual for that menu :(
 

yonef

Distinguished
Jan 22, 2008
289
0
18,780
@boudy

That's the options taht Twoboxer talk about, but I have already did all kind of combinations and this does not disable auto-brightness :(
PSM (first on the pic.) is just different presets that is predefine by the vendor.
CSM (second) is setting for color temps.
XD (third) is setting available only for TV mode (it clears noise and stuff like this)
 
Have you tried using the "Game" setting for picture type?

I really don't want to go looking for that manual again lol, but maybe that setting disables brightness pushing for video signals.
 

yonef

Distinguished
Jan 22, 2008
289
0
18,780
@ boudy, I have contacted LG customer support 2 days ago... still nothing. I hope they will replay soon. will see.

@ Twoboxer, I have running "game" setting most of the time. None of these settings has to do with auto-brightness :(

OK guys, thanks for the the response, lets see what LG Customer support will come for.
I'll post the results in case someone else wants to disable this "feature" :D