Question How to Disable Secure Boot on Asus P8Z77-V?

blue_rays

Distinguished
Aug 1, 2014
50
0
18,530
0
Hi there, I want to clean install windows 10 in UEFI mode on my brand new SSD (250GB Sata).
I know that I need to set boot mode to UEFI and disable secure boot.

I have an Asus P8Z77-V mobo, and here is how my boot menu looks like:
View: https://imgur.com/19ncBQC


CSM:
View: https://imgur.com/3vezG9Q


Secure boot menu:
View: https://imgur.com/yCiwjO7

View: https://imgur.com/0KpOgr8

I don't have any Idea how to disable secure boot before staring windows installation. How can I do that?
 

blue_rays

Distinguished
Aug 1, 2014
50
0
18,530
0
Just run the installer and install it. I've installed/reinstalled Windows10 many times with secure boot enabled and never realized it was supposed to be disabled.

But if you really think it's necessary...enable CSM mode.
As you can see in scrrenshots, CSM is already enabled and that's not a real workaround.

I found that if I remove keys, secure boot turns off, and when I install default key, it turns back on.
 
...
I found that if I remove keys, secure boot turns off, and when I install default key, it turns back on.
That's probably what my UEFI does too when I disable secure boot; that is, it just removes the default keys. To turn it back on I have to install the default keys.

If CSM is enabled you shouldn't have secure boot enabled since in compatibility mode it's running like BIOS does, using the MBR not EFI to boot the OS. Secure boot does not work MBR.
 
Last edited:

blue_rays

Distinguished
Aug 1, 2014
50
0
18,530
0
That's probably what my UEFI does too when I disable secure boot
Thank you for sharing your experience.
Do you own an asus mainboard? AFAIK asus does not have an option to disable/enable secure boot.

If CSM is enabled you shouldn't have secure boot enabled since in compatibility mode it's running like BIOS does, using the MBR not EFI to boot the OS. Secure boot does not work MBR.
I have used an MBR HDD for 3 years and CSM and secure boot have always been enabled on my mainboard, but I didn't know that I need to disable CSM.
 
Last edited:
....
I have used an MBR HDD for 3 years and CSM and secure boot have always been enabled on my mainboard
....
That is really strange and probably needs an EFI expert to explain how it's possible. The only way I can imagine that happening is if your BIOS is lying to you about enabling secure boot so it's probably worthwhile checking in Windows to see if it's really enabled. Just run the Device Security settings app (type it in Cortana) and it will tell you if Secure Boot is enabled.
 

ASK THE COMMUNITY