how to fix blackscreen with cursor after login windows 7

FearAndLovely

Honorable
Dec 18, 2013
2
0
10,510
0
LAPTOP CONFIG:TOSHIBA satellite c850
WINDOWS 7 ULTIMATE*64bit

when i start my windows it starts normally and then login page appears and when i login a black screen appears and stays on there forever...
things i have tried-1.wait for few minutes cause you have many starup programs...but i didn't have many....only adobe,avast
2.all safe modes works properly....even startup repair didn't give any error.
3.installed regcurepro in safemode and it fixed all....but no progress from blackscreen...
4.all functions work properly....like screen brightness and primary screen..even in safe mode and set to primary
FIRST TIME when it apperared blackscreen it popped a window saying
"DWM.EXE STOPPED WORKING,APPLICATION ERROR!"
this is all the information i have from 3 days...now i'm publishing this...PLZ HELP!!!
 

9690austin

Reputable
Mar 6, 2014
2
0
4,510
0

Mine Toshiba is doing the same thing after the computer froze I turned it off now it lets me Log in but goes to a black screen and cursor. Trying to do a restore to a previous point fails because it says that there are none to go back to.
 

Senor_Coconut

Reputable
May 14, 2014
2
0
4,510
0
Hi all, I too have been looking all over for a solution that didn't require reinstall. My situation;

Windows 7 Professional 64 bit
HP ProBook 6570b with SSD
All went fine for about 6 months
Then the startup time started to increase without
After login screen a long pause (appox 30sec) with a black screen with cursor
I tried starting up in low res safe mode to no avail
I ran Malwarebites and found nothing
I looked in the registry and changed the startup value (userinit contained additional data to startup HP security manager) but alas

Anyway - I did this last week and after receiving Windows updates a few minutes ago (which included a reboot) the problem is gone. Don't know if it had any to do with the above mentioned other attempts, but it might be worth mentioning
 

Senor_Coconut

Reputable
May 14, 2014
2
0
4,510
0


Sorry - my bad. The issue returned after some new updates. But I think I fixed it good this time.

I tried a lot of the things that were recommended such as:

- Booting in low-res mode
- Deleting and re-installing graphics drivers
- Creating a boot log, which did show several drivers did not load similar to this log
- Inspecting BIOS and considering switching from AHCI to IDE like some threads suggested but after seeing the warning that this might require re-installation quit the process.

The boot log didn't help much but one forum suggested viewing the event log (specifically system events) and inspecting it for any errors that might indicate where things went wrong.

In the event log I saw 5 consecutive warnings during boot, followed by 1 error - all in about the time the black screen appeard. The error stated:

"the hp cue devicediscovery service service hung on starting".

Through this hint I found this advice and after I switched the HP CUE service to "manual" - tadaaa! I have a speedy boot again and all still seems to work fine.

I hope this helps others too. And please also check the event viewer first to see if this is your probleem too, don't just switch off the HP CUE service but see for yourself what might be causing your black screen at startup!

UPDATE: This may be very relevant since I too have a HP CM1312 printer on my network. So it seems to be HP printer driver / services related
 
Thread starter Similar threads Forum Replies Date
B Windows 7 2
Similar threads
Question Cursor jumps

ASK THE COMMUNITY

TRENDING THREADS