[SOLVED] How to fix Corsair iCUE software showing a red exclamation mark on my Vengeance RGB RAM?

MarkLawrence_1993

Prominent
Jul 6, 2019
15
1
525
1
Hello guys! My Corsair iCUE software, as what in the title states, is having an issue with my Corsair Vengeance RGB 32Gb DDR4 3200mhz RAM. There is a red exclamation mark inside a triangle indicating that there is a problem. The software is detecting the hardware but just not able to control anything from it (especially its RGB lights). It all started after I clean reinstall my OS due to some earlier problems which were eventually solved but when I reinstalled iCUE I noticed that my RGB peripherals (i.e. keyboard mouse, mousepad, headset and headset stand) have delayed lighting (by the word delayed what I mean is that when I click a key or press the mouse button, the lights shows up 2-3 seconds after). So this prompt me to open iCUE but I haven't noticed anything wrong. So I uninstalled and re-installed iCUE and opened it and boom there it shows the red exclamation mark beside the RAM logo. What I have done already are as follows:

  1. Uninstall the iCUE (once again but this time following Cosair's instruction of doing a complete uninstall including deletion of Corsair's registry folders in 'regedit')
  2. Installed an older version of iCUE from 3.35.152 to 3.34.161
  3. Seat and re-seat the actual RAM on my motherboard (even tried on swapping their slot placements)
  4. Unistalled other RGB controlling softwares (i.e. Asus Aura and Wallpaper Engine but reinstalled Wallpaper Engine again because it did nothing)
  5. Disabled Nvidia GeForce in-game overlay (it did removed the red exclamation mark but only for it to reappear after a few moments)
Also I noticed that when I restart my pc the exclamation mark momentarily goes away and iCUE is back in control of my RAM however, the RGB lights are delaying again and the entire software lags (the software operates normally only when the red exclamation mark is present again and do not have control to my RAM). I've tried searching corsair forums and I came to know that this is a known issue but none of them threads solved my problem. My pc is working just fine for the last 2 years and iCUE is not having any problems with my RAM back then and to other RGB controlling software previously installed. Please help me guys. I'm literally exhausted for the past 2 days trying to solving this.

SPECS:
Intel Core i7-6700K 4 GHz Quad-Core Processor
Corsair H115i 104.65 CFM Liquid CPU Cooler
Asus ROG MAXIMUS VIII HERO ALPHA ATX LGA1151 Motherboard
Corsair Vengeance RGB 32 GB (4 x 8 GB) DDR4-3200 CL16 Memory
Western Digital Caviar Black 2 TB 3.5" 7200RPM Internal Hard Drive
Samsung 860 Pro 512 GB 2.5" Solid State Drive
Asus GeForce RTX 2080 8 GB Turbo Video Card
Corsair AXi 1200 W 80+ Platinum Certified Fully Modular ATX Power Supply
Corsair 780T ATX Full Tower Case
Microsoft Windows 10 Pro OEM 64-bit
Kaspersky Internet Security

P.S.
Also, I'm having problems on how to post a question or thread in Corsair Forums. I just can't find any button to open a new thread. How to do it?
 

ASK THE COMMUNITY