Question How to fix flickering text in Windows display settings ?

grandviken

Distinguished
May 10, 2014
15
0
18,510
0
https://puu.sh/HEEm7/e1df70817a.gif

Link above is what is currently occurring when i go to change display settings in Windows, i open that to change one of two monitors refresh rates and the text is constantly flickering. This makes it so when i click the option it immediately defaults everything to my first monitor when i go to change the second monitor's settings ?

I have a 144hz monitor and a 75hz monitor, the 144hz is plugged in using DP and the 75hz is HDMi, ive swapped hdmi cables to no avail, updated graphics card driver (using rtx 2060)
All of this started yesterday after plugging in an external capture card which works but has caused some issues it seems, ive since removed and unplugged the device restarted pc, ran cmd scan and fixed issues there.

I'm not sure what exactly is going on. The nvidia control panel also only shows 60hz max on the display that supports 75hz so im genuinely confused, because when the monitor is plugged in by itself i can only select 72hz.
 

Lutfij

Titan
Moderator
Make and model of our monitors? By update, did you use DDU to uninstall your current GPU drivers, then using the latest drivers from Nvidia's support site in an elevated command, i.e, Right click installer>Run as Administrator?

Make and model of your capture card? Make and model of your PSU and it's age? OS version? BIOS version for your motherboard?
 

grandviken

Distinguished
May 10, 2014
15
0
18,510
0
Make and model of our monitors? By update, did you use DDU to uninstall your current GPU drivers, then using the latest drivers from Nvidia's support site in an elevated command, i.e, Right click installer>Run as Administrator?

Make and model of your capture card? Make and model of your PSU and it's age? OS version? BIOS version for your motherboard?
Yes i used DDU to uninstall drivers, i always run nvidia driver as admin.
Monitor 1 main - MSI optix MAG24C (DP cable)
Monitor 2 - Samsung C24F390 (HDMI cable)
Capture card is a MIRABOX USB3.0KHDMI card
PSU is a evga GQ series 850W 80+ gold (3 yeas in age [eco mode not on]
WIndows 10 home Build 19041.928
Mobo is Asus TUF b450 PRO GAMING using latest bios

This issue started to occur after i used the capture card, it was fine before hand, again ive already unplugged the capture card as it doesnt install drivers from what i saw since it only plugged in through USB
 

grandviken

Distinguished
May 10, 2014
15
0
18,510
0
UPDATE i fixed the issue by unplugging everything and plugging it back in to the back of the mobo one by one. The only issue now is that i cant change the refresh rate to 75hz and it's stuck at 60 ?
 

ASK THE COMMUNITY

TRENDING THREADS