Question How to fix laptop keyboard problem where you can't type normally if you dont hold down space bar?

Oct 17, 2020
1
0
10
0
TL;DR pressed alt f4 and space multiple times in VRChat, keyboard wouldn’t type (built in keyboard in dell inspiron 15 5577) if i didnt hold down space, tried everything to fix it (fresh windows install at the end) but didn't work

So, the problem started when i was playing VRChat and was pressing space bar very fast repeatedly to jump. The game stopped responding and i assumed it was gonna crash. So i pressed alt + f4 multiple times. It didnt go away. I restarted my pc but then the problem appeared.

i couldn't use my keyboard unless i held down space. And when i would let go it would type n2d or something like that and probably also press some function keys (because everytime i let go my sound would also toggle from off to on or on to off.

So i searched hours and hours for solutions.

I tried:
uninstalling all keyboard drivers amd reinstalling them
switching to another language as primary language as shown in multiple youtube tutorials.
Partially resetting my pc (reset pc but keep files option)
Complete reset of pc
Fresh windows install from usb stick

Nothing worked, this issue was happenning even when i was entering my name during the fresh install of windows

Before the uninstalls if i would plug in another keyboard it would behave the same but now if i use another keyboard it types good. However now that i already have a fresh install of windows, have nothing to lose and dont actually own that keyboard i used i just want to get rid of this problem all together.

so please if you have any idea what A possible solution can be please feel free to answer.
 

ASK THE COMMUNITY

TRENDING THREADS