How to fix PCie PSU cable for GPU (RTX 2070)?

Dec 23, 2018
3
0
10
0
I just finished my first build, with the MSI Armor RTX 2070. The PSU I’m using is the Corsair Rm750x in white, my issue is only a cosmetic one (I’ll provide a photo), the GPU uses 6 and 8pin connector so when it’s plugged in the cable creates this ring. To me it just bothers me a lot lmao, I’d prefer it to look a bit more clean. I’m only using one 6+2 cable that splits, so I’m wondering would adding another 6+2 cable clean it up? Or is it where the cable is routed that’s making it look this way? I’ve watched other similar builds and theirs don’t look as weird as mine. Haha. Any suggestions help. Thanks!

Photo:
https://imgur.com/a/wZHYGj4
 

kiss-method

Prominent
Oct 26, 2018
316
0
460
96
It just looks like the design of your PSU cabling is working against you.

Other PSU may have 2 seperate wires as 6 pin, so they're easier to make look nice.

You could buy some mini tie wraps and try route/ clean them up. You can pull the two wires together with tie wraps, but careful not to stress the connectors (don't go too tight with your wraps to the point of where they twist the connectors on gpu
 
Dec 23, 2018
3
0
10
0


I thought doing that would work, but the problem is the Pcie cables that came with my PSU are both daisy chained 6+2s :/ So adding another one would just make it look even more cluttered. I guess what I’ll have to do is buy a Pcie set that isn’t split.

 
Dec 23, 2018
3
0
10
0


Yeah I think you’re right, when I bought the PSU and saw photos of other people using it I was under the impression that the cables were sleeved differently. The set I got is the stiff plastic ones lol. I’ll probably just do what you suggested or just buy some separate Pcie cables to clean it up. Thank you!

 

ASK THE COMMUNITY

TRENDING THREADS