How to fix the screen tearing?

Ludogorets

Honorable
Sep 13, 2013
213
0
10,680
0
I've recently bought new GPU (MSI AMD Radeon HD 7850 2GB) but in some games (like Far Cry 3,Outlast) i get horrible screen tearing.... When i turn "vsync" on,it kinda fixes it,but i get enough lag to interrupt the gaming experience. So is there a way to fix it without enabling vsync? :)

My Specs:

CPU -AMD Athlon (II) X4 641 Quad 2.8GHz
RAM - 8GB
GPU - AMD Radeon HD 7850 2GB
 

Ludogorets

Honorable
Sep 13, 2013
213
0
10,680
0


I'm playing games on 1600x900 resolution 75 Hz. LCD Aos monitor.
 

Ludogorets

Honorable
Sep 13, 2013
213
0
10,680
0


Is there a fix without enabling vsync? please help
1600x900 60Hz :(
 
There is no way to stop tearing without V-sync. G-sync, in a few months, will be the first alternative to V-sync, but will require special hardware in the monitor.

If V-sync is causing a lot of slow down and lag, you may need to use triple buffering, if it is an option. For DirectX, you may have an option to increase "Maximum Prerendered frames", and set that to 2. Either way, you may get some juddering if you cannot maintain your refresh rate. You may need to also turn down settings for a better experience and you may also find turning the monitor down to 60hz to be helpful in reaching your monitors refresh rate with your FPS.
 

Ludogorets

Honorable
Sep 13, 2013
213
0
10,680
0


It doesn't seems to work :(.. But what if i get a new cable? is this gonna fix the screen tearing? I'm currently using DVI-I to VGA cable,but what if i use DVI to DVI? My monitor got 2 ports.. VGA and DVI-D,my GPU has DVI-I and HDMI. What if i use DVI-D to DVI-I (dunno if that kind of cable even exist) will fix the problem? i remember i've tried my PC with a 28inch TV with HDMI Ports,and i couldnt see any Screen tearing,but somehow the quality was bad...
 

Ludogorets

Honorable
Sep 13, 2013
213
0
10,680
0


When i've used my old GPU GT 430 2GB,i couldnt notice any screen tearing... now ive bought AMD Radeon HD 7850 2GB and got lots of tearing.
 

Ronaldspiers

Honorable
Sep 25, 2013
333
0
10,860
25


I think that is because your FPS is higher than your monitor refresh rate with that GPU. V-sync is the only way to deal with it unless you can turn the resolution up.

 

a1blaster

Honorable
Sep 14, 2013
574
0
11,060
28


7850 is a 2012 card and 430 is a 2010 card...you need to update bios
 

Ludogorets

Honorable
Sep 13, 2013
213
0
10,680
0


And How can i do that ? :)
 

Ludogorets

Honorable
Sep 13, 2013
213
0
10,680
0


Hmm v-sync causes lots of mouse lag,isn't there a way to stop that lag caused by the v-sync? ain't there any programs,or drivers that can do that?
 

17seconds

Champion
Moderator

That's what Nvidia's Adaptive VSync is for. It only turns on VSync at framerates above 60, so there is no mouse lag. Triple buffering is supposed to help as well, but only on OpenGL games.
 

Ludogorets

Honorable
Sep 13, 2013
213
0
10,680
0

Yeah i know that Nvidia adaptive VSync does that,but my GPU is AMD not NVIDIA :(

 

Kerns76

Reputable
Aug 9, 2014
4
0
4,510
0
Yeah i know that Nvidia adaptive VSync does that,but my GPU is AMD not NVIDIA :(

[/quotemsg]

Hi! I had the same issue with this when i upgraded from my 550ti to a EVGA geforce gtx 760 2gb . I had a 60hz monitor with VGA only. So i figured i would try to connect the computer to my tv via HDMI and the horizontal lines were gone! My tv is 39". 1920x 1080p. Nothing special. But hey it worked! Good luck if you havn't already solved this.

 

srbfantom94

Reputable
Dec 3, 2014
3
0
4,510
0
Its because you use vga to dvi, or any other cables dvi - hdmi.
Solution is that you use vga - vga, or dvi -dvi and you will not have any flickers and tearing.
 


Flickering is different than tearing. Tearing is not fixed by anything but V-sync, and now G-sync (in gaming). Freesync is coming soon. Cables have nothing to do with it.

And why is this thread continuing to be resurrected. Bad cables can cause some flickering and possibly lines, but that is not tearing.
 

Ludogorets

Honorable
Sep 13, 2013
213
0
10,680
0




I'm sorry,I've forgot to pick a solution :( Anyway,bystander is right... I had lots of Flickering,when I used VGA cable but now for months im with HDMI cable and the Flickering is gone :), according to Tearing,I've been searching for years a way to fix it,without the mouse lag,thats caused by Vsync, and found only 1 solution,that works great so far. It's a program called D3DOverrider (Google It) But it seems that it works only in old games,like AC4 Black Flag,FC3..etc news like Unity,FC4 probably wont work (Not tested)

 

dannydragon

Reputable
Jan 15, 2015
1
0
4,510
0
The only solution I have found is to enable Vsync (triple buffered) and ALSO to limit your fps to 1 below your monitor's refresh rate. My monitor is 60hz so I limit my fps in game to 59fps using console. This should resolve the tearing and mouse lag.
 

Tokke89

Reputable
Dec 7, 2014
13
0
4,510
0
Ive got a way to make it less noticeable. If you have a monitor or tv connected to the pc with hdmi try and look for a game mode or a pc dvi mode. It reduces the screentearibg alot. It will not be away completely as that will only be possible with vsync but it will make it far less noticeable.
 

ASK THE COMMUNITY

TRENDING THREADS