How to fix Wifi Limited connection issues in Windows 8

adguglani

Honorable
Oct 21, 2013
31
0
10,540
1
My internet connection has some protection. For each device I use to run internet on, I have to log in to the network from the browser after connecting to Wifi.

I cannot access the Internet without logging into my network from the browser. In the status bar of my Windows 8 laptop, it shows a yellow triangle on the signal bars saying 'Limited.' I'm not able to log in to my internet from the browser. How do I fix this issue?
 

daniel atlas

Honorable
Dec 29, 2013
15
0
10,520
1
This is a problem that has had wide documentation across the web: windows 8 randomly drops wifi. Here is the best way to fix it:

right click the icon in the icon for wifi in the bottom right near calender. Click trubleshoot problems, and let it resolve itself. The trouble shooter should reset the wifi adapter, if it doesn't try again later. This should solve the problem.

Microsoft released windows 8 with this massive bug, but never responded with a single update, it was really disappointing.
 
have you actually looked at the cause of this issue? Microsoft does not update the firmware in peoples wireless routers for them. Some of the wireless routers are out of spec, you can connect to them with a high speed wireless device and things work as expected until some low speed device connects, the router then drops down to the lowest speed device for all connections. It is often a simple update of the firmware of the router in many cases.
Or a better router, one with two radios. How can Microsoft provide a update for something like that? it is not a bug in the OS, it is not a bug device driver that is installed on windows. It is external to the OS and the PC



 

daniel atlas

Honorable
Dec 29, 2013
15
0
10,520
1


I may have overreacted a little, but I have run this on brand new hardware with up to date firmware on all parts of the chain, and still had the problems. So I appreciate your advice, but I have found that it doesn't work. Also, I found that 8.1 doesn't have this problem, so I might suggest that. It is easy to upgrade.
 
I know this is older post, but wanted to add... Windows 8.1 still does not support WPA, so if that is the highest level your router goes, it won't work. Trying to find a work around with third party WiFi utilities but so far no luck.
 

DBeeMadasF

Reputable
Aug 13, 2014
1
0
4,510
0
My Wifi has dropped from my Toshiba Satellite with Windows 8.
PC is not even 5 months old
The mere fact that Buyers such as myself have to even do some work around is pure crap.
Internet doesn't drop on our Tablets. So if Toshiba &is Windows 8 want to be in big leagues then get it Right or don't get involved at all! I'm disgusted by the whole thing. Thums Down to both Toshiba & Windows 8/touch screen. Worst Investment I could have made. Never again!!!!
 

orlbuckeye

Distinguished
May 1, 2009
1,525
0
20,160
177
I would also try seeing if you can connect to a free network like Panera Bread or Mc Donalds. If you can connect there then you know it's you local setup. Which could be a conflict with your wireless card brand and router brand. It could also be you need to update the wireless card driver on the PC. I would also try connecting with a wired connection.
 

zaklac

Distinguished
Aug 16, 2010
1
0
18,520
1


I have tried the wired connection, as a matter of course it is OK. It is NOT a router firmware problem also. My second PC with Windows 7 can connect correctly to the router. It is Win 8 problem! I have tried to restart the connection several times and sometimes the connection has been established. I think it is a good idea to turn off the protection and try unprotected WiFi connection.
 

orlbuckeye

Distinguished
May 1, 2009
1,525
0
20,160
177


You not looking at the whole picture. More of a factor then the OS is your Wireless Card (hardware) and the driver for that card. Your windows 7 machine has no trouble which most likely has a different wireless card and a driver that goes with it. I have Windows 7 and Windows 8 and have now problems. My windows 7 machine has a Intel wireless card and my Windows 8 has an Intel card but one is a 802.11 N and the other in 802.11 AC. So because Windows 8 works wired the problem like I said your wireless card (either the card itself of driver). Most likely a driver issue. Got your laptops support and DL the driver to match your wireless card.


 

Corrinna Gordon

Reputable
Sep 3, 2014
2
0
4,510
0


if you ask me you computer is disconnecting to join on to another connection i my self having the same problem its something to do with the setting to internet as i fixed it once before but i reset my laptop and its back and i have forgotten where the setting are but its defo a setting
 

myeagley

Reputable
Sep 21, 2014
1
0
4,510
0
Go to the battery icon on the bottom tool bar and right click. Then go to power options->change plan settings->change advanced power settings->wireless adapter settings->power saving mode-> then make sure both plugged in and wireless are set to maximum performance. Every time windows does an update this resets and you have to manually go back and reset it again. This works every time for me.

 

tomshardware11

Reputable
Sep 26, 2014
1
0
4,510
0
I had this same problem. I bought a brand new PC with Windows 8.1, and my wifi connection would work just fine for a while, and then stop working even though it showed as having a good wifi signal and other devices had no issues. I'd restart my computer, and it would work again fine for a while. I ended up uninstalling the wifi driver and reinstalled it, and I haven't had any problems since.
 

ariawatson

Reputable
Nov 17, 2014
4
0
4,510
0
I had the same problem at my Toshiba Satellite with Windows 8. @daniel atlas I tried the solution you suggest above and also Turn Off and Turn on Wireless Router, but didn't work for me. But configuring the wireless adapter settings fixed the issue. These links help me to configue adapter settings. http://www.intel.com/support/wireless/wlan/sb/CS-025393.htm, http://windows8.iyogi.com/troubleshooting/fix-windows-8-wi-fi-connectivity-issue.html
 

andwings2go

Reputable
Dec 1, 2014
1
0
4,510
0


This was my problem 100% I'm plugged in close to my router, went ten rounds with FIOS and my router not having decent range. Been going round and round with this for almost a YEAR. Now I'm pissed about an awesome Lenovo laptop that I returned to HH Gregg that I bought on closeout. All because of a stupid battery saving glitch with Windows 8. BTW once it got mixed up, plugging back into power didn't ever solve it. No education about the issue at FIOS tech support or HH Gregg has me so mad I can't even find my words. Thanks dude, at least this Toshiba I never wanted in the first place works OK now.

 

Drew John

Reputable
Dec 26, 2014
1
0
4,510
0
Hey man don't like apologize to him, fuck him you didn't say anything wrong , and btw I tried to fix this all day in my new comp and after seeing your post I fixed it with the click of 2 buttons So thanks man ah


 

papa M

Reputable
Feb 9, 2015
5
0
4,510
0


 

papa M

Reputable
Feb 9, 2015
5
0
4,510
0


 

orlbuckeye

Distinguished
May 1, 2009
1,525
0
20,160
177
We have that at my work. When you login to the internet you go to a disclaimer page first. I just explains its's free network and my business is not responsible if uses of this open wireless get hacked.
 

Compuwolf

Reputable
Feb 15, 2015
1
0
4,510
0
One possible solution that has worked for me is to open command prompt (cmd) as an administrator. Right click on command prompt and you should see run as administrator. Enter "netsh winsock reset" without the quotes. Then restart you computer.

Believe it or not, sometimes this issue can be temporarily resolved by rebooting the modem.

I have not found a permanent solution.
 

ialhabsi

Reputable
Feb 20, 2015
1
0
4,510
0




This is how I fixed the problem. It is working 100% with me now.
1-Right click in the wifi icon and choose network and sharing center.
2-Click in the name of ur wifi (in blue) to open wifi status window
3-Click in the wireless properties
4-Mark the dialog "Connect even if the network doesn't podcasting its name (SSID)

Hope it will work for you. Best regards
 

Similar threads


TRENDING THREADS