• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question How to force USB headphones to use 'USB Audio Device' driver?

Gron113

Reputable
Apr 1, 2016
57
0
4,640
4
Hi all,

I have a Logitech G933 USB headset, which I mainly use for gaming. I recently got Dolby Atmos on Windows, and I really like how the surround works. However, Atmos won't show up in the 'Spatial Sound' menu in the sound control panel unless the headphones are using the windows default USB audio device drivers.

It's simple enough to set these drivers up. I simply go to Device Manager, go to 'Sound, Video and game controllers', scroll to the G933, Update Driver, pick from driver on my PC, and then pick USB Audio Driver. THEN Atmos works completely fine and I'm able to set it from the menu.

However, sometimes when I turn my PC on, it decides to go back to whatever default drivers the G933 came with, and I have to do the whole process again. It only takes about 30 seconds to do, but it's gotten quite annoying to be honest.

Is there any way to set the 'USB Audio Driver' from Windows as the default, and completely stop the headphones from setting their own drivers? I think I have set my PC to not use 'Fast Boot', because I'm using an SSD. I fear that may be the problem - somewhere along the pipeline the PC is resetting it's audio drivers.
 

ASK THE COMMUNITY