[SOLVED] How to get the 144hz option on my Intel® UHD Graphics 630?

mzk777

Honorable
Mar 25, 2015
26
0
10,530
0
I have it connected via DVI-D through my MSI Z370-A Pro to my benq xl2411z and I can only the see the option for 59 / 60hz. What I can do ? I have the latest driver installed, I completely uninstalled my old nvidia driver using DDU, I have given the boot priority to the onboard graphics on BIOS, and I uninstalled and installed the driver twice. I don't know what else to try....I had quit gaming for good, but looking at my mouse pointer moving on 60 hz hurts my eyes.

View: https://imgur.com/WeY2Hln


Thanks in advance everybody!
 

--SID--

Notable
Jan 23, 2021
1,010
217
1,140
36
MSI Z370-A Pro
From the specsheet:

1 x DVI-D port, supports a maximum resolution of 1920x1200@60Hz

You have to connect the monitor with DP but as long the monitor only support 144 Hz with Dual Link DVI-D it's impossible to get 144 Hz with the onboard graphics.
 
Last edited:
make sure there is no option in the monitor's OSD menu that needs to be altered to allow 114Hz, which could be an "overclock".

make sure the OS has the proper refresh rate dialed in;
Windows 10: Settings > System > Display > Advanced Display Settings > Display adapter properties, "Monitor" tab

and make sure you have any BenQ drivers available installed.
check Optional Updates in the OS and the BenQ product support page.
 

--SID--

Notable
Jan 23, 2021
1,010
217
1,140
36
MSI Z370-A Pro
From the specsheet:

1 x DVI-D port, supports a maximum resolution of 1920x1200@60Hz

You have to connect the monitor with DP but as long the monitor only support 144 Hz with Dual Link DVI-D it's impossible to get 144 Hz with the onboard graphics.
 
Last edited:

mzk777

Honorable
Mar 25, 2015
26
0
10,530
0
make sure there is no option in the monitor's OSD menu that needs to be altered to allow 114Hz, which could be an "overclock".

make sure the OS has the proper refresh rate dialed in;
Windows 10: Settings > System > Display > Advanced Display Settings > Display adapter properties, "Monitor" tab

and make sure you have any BenQ drivers available installed.
check Optional Updates in the OS and the BenQ product support page.
on the windows settings, It shows a maximum of 64hz, after the driver install it became 60hz.
 

mzk777

Honorable
Mar 25, 2015
26
0
10,530
0
From the specsheet:

1 x DVI-D port, supports a maximum resolution of 1920x1200@60Hz

You have to connect the monitor with DP but as long the monitor only support 144 Hz with Dual Link DVI-D it's impossible to get 144 Hz with the onboard graphics.
That explains it, Thanks!!
I guess I will have to live with it lol.
 

ASK THE COMMUNITY

TRENDING THREADS