Question How to lock every application i run to 60 Hz?

Timur Nazarovs

Honorable
Aug 31, 2014
16
0
10,520
0
I have just recently gotten a new PC with a GTX 770 which is more than enough for me in terms of gaming. One problem I have though is that my monitor still remains 60 Hz so whenever i launch a game, e.g dying light or saints row (those that don't have refresh rate settings in their display settings,) I am unable to play it in full-screen since it displays at a higher refresh rate than my monitor can support, I know this because whenever I go full screen at native resolution my monitor prompts me that I need to change it to 60 Hz. Activating V sync doesn't fix it, neither does writing "-refresh 60" in steam's launch options. Is there any way that I can lock every application/game I launch to 60 Hz so that I can actually play it full-screen.

Specs:
CPU: A10-7860K
GPU: Asus GTX 770 2gb Vram
RAM: 8GB 1600Mhz DDR3 Kingston Ram
120gb SSD + 2tb HDD
I don't think the rest are necessary
 
First off, some monitors that have a claimed 60Hz refresh are in reality 59Hz, or 59. something (59.7 for instance). To test this, both Nvidia Control Panel and Windows Monitor settings have a 59Hz option you could try. Try setting it to that and see if it solves the problem.

You could also try disabling Vsync in game and instead turn it on in Nvidia Control Panel.
 

Timur Nazarovs

Honorable
Aug 31, 2014
16
0
10,520
0
I believe my display is Hp Pavilion 2009M (1600x900)
NCP only offers refresh rates from 60,70,72,75 and 85 but my monitor only supports 60.
Windows Monitor Tab also displays nothing under 60, and I am certain that I have no viruses as I recently formatted all the hard drives and reinstalled windows 10 on it, only having installed a few essentials (browser, discord, steam, etc...) and games.
 

Third-Eye

Distinguished
Jun 26, 2011
280
37
18,720
3
I have just recently gotten a new PC with a GTX 770 which is more than enough for me in terms of gaming. One problem I have though is that my monitor still remains 60 Hz so whenever i launch a game, e.g dying light or saints row (those that don't have refresh rate settings in their display settings,) I am unable to play it in full-screen since it displays at a higher refresh rate than my monitor can support, I know this because whenever I go full screen at native resolution my monitor prompts me that I need to change it to 60 Hz. Activating V sync doesn't fix it, neither does writing "-refresh 60" in steam's launch options. Is there any way that I can lock every application/game I launch to 60 Hz so that I can actually play it full-screen.

Specs:
CPU: A10-7860K
GPU: Asus GTX 770 2gb Vram
RAM: 8GB 1600Mhz DDR3 Kingston Ram
120gb SSD + 2tb HDD
I don't think the rest are necessary
Open Nvidia Control panel and go to Change Resolution under Display. Click on customize and you will have the option to create a custom resolution with a specific refresh rate of 59hz. Try testing the 59hz refresh rate in fullscreen from the game options to see if it changes anything
 

ASK THE COMMUNITY

TRENDING THREADS