[SOLVED] How to make i7-8700k run at 5GHz only when under load

Gregkar

Honorable
Dec 18, 2013
5
0
10,510
0
Is there a way to make my CPU run stock and only jump to 5Ghz when it needs to? fx under gaming, or video editing etc..?



I have OC it at constant 5Ghz now but i live in a warm country and during summer temps rise A LOT, i have 39-40C in idle windows enviroment, and i use single AIO cooler.
 
Last edited:

Digitrax

Honorable
Nov 3, 2014
40
5
10,545
3
Is there a way to make my CPU run stock and only jump to 5Ghz when it needs to?
Yes.

1. Use adaptive voltage (not "Manual") to keep temps lower.

2. Make sure at least C-states C0-C2 are ENABLED; you may limit C-states to C2* (or disable C3, C6, C7, etc.) for faster transient response (so you won't be shutting down clocks or powering down cache).
*(Note: If you want the computer to be able to "Sleep", enable/limit to C3).

3. Make sure you're not running Windows 10's "Performance" power plan. You can edit the "Balanced" plan to use all of the "Performance" plan's settings (except "Minimum Processor state, which you can set as low as 20%), but (at least in b1909) even when you drop "Minimum Processor" under the "Performance" plan, it pegs it at a constant 100% — (apparently disables Windows 10's driver support for Intel's "Speed Shift").
 
Last edited:
Reactions: Gregkar

grimfox

Distinguished
Jun 2, 2009
942
26
19,390
144
Normally you would increase the multiplier to get to max frequency. Then the CPU can adjust the multiplier as needed between min and max that you establish as needed. It sounds like you've adjusted the clock. The clock is normally 100Mhz so to get 5Ghz you'd set the mult to 50. There are some other settings that could lock the CPU at maximum multiplier.

In general I would look to see if there is a video or tutorial on overclocking with your specific motherboard. Or one from the same manufacturer or series. That might give you a better idea of how to overclock your specific system so it isn't locked at full speed all the time.

If you want more specific help then you need to post your specs and what settings you changed in your bios to get the overclock you have now.
 

grimfox

Distinguished
Jun 2, 2009
942
26
19,390
144
hmm you might try reducing your voltage a few ticks from 1.35. You'll want to test your results to see if it's stable. But less votlage should yield less power and therefore lower temps. I am not sure why the clocks are static at 5GHz. it's looks like that tutorial is adjusting the multiplier. It's been awhile since I've been in my bios. I think the only 3 things I changed in mine were the multiplier, enabling the xmp profile and setting the boot drive. I have an ASUS ranger Viii with a 6600k.
 

Piske

Reputable
Nov 28, 2016
22
3
4,525
1
CPU normally has C-states. It reduces its speed to reduce power consumption. If you overclock your CPU, it's still possible to do that. The CPU will "underclock" when all the "horsepower" are not needed. For example, i have my E5 1650 v1 at 4,6ghz but right now is operating at 1200mhz because there is no load.

Is it possible to be at stock without overclock, and when you need it go to 5ghz? I don't think so. Either you overclock it or not. But not both two at the same time.
 

Digitrax

Honorable
Nov 3, 2014
40
5
10,545
3
Is it possible to be at stock without overclock, and when you need it go to 5ghz? I don't think so. Either you overclock it or not. But not both two at the same time.
Of course it is! This is the difference between enabling and disabling C-states (and also setting a "Manual" vs. "Adaptive" core voltage).

My 8700K typically idles at 800Mhz, but will boost all cores to 5.0GHz under load. I used an adaptive voltage (w/a -50mV offset in my case) and a (relatively) low uncore ratio (4.4GHz).
 
Reactions: Zanathon

Digitrax

Honorable
Nov 3, 2014
40
5
10,545
3
Is there a way to make my CPU run stock and only jump to 5Ghz when it needs to?
Yes.

1. Use adaptive voltage (not "Manual") to keep temps lower.

2. Make sure at least C-states C0-C2 are ENABLED; you may limit C-states to C2* (or disable C3, C6, C7, etc.) for faster transient response (so you won't be shutting down clocks or powering down cache).
*(Note: If you want the computer to be able to "Sleep", enable/limit to C3).

3. Make sure you're not running Windows 10's "Performance" power plan. You can edit the "Balanced" plan to use all of the "Performance" plan's settings (except "Minimum Processor state, which you can set as low as 20%), but (at least in b1909) even when you drop "Minimum Processor" under the "Performance" plan, it pegs it at a constant 100% — (apparently disables Windows 10's driver support for Intel's "Speed Shift").
 
Last edited:
Reactions: Gregkar

Piske

Reputable
Nov 28, 2016
22
3
4,525
1
Of course it is! This is the difference between enabling and disabling C-states (and also setting a "Manual" vs. "Adaptive" core voltage).

My 8700K typically idles at 800Mhz, but will boost all cores to 5.0GHz under load. I used an adaptive voltage (w/a -50mV offset in my case) and a (relatively) low uncore ratio (4.4GHz).
I also talked about C-states, but that is not an overclock . It's just a power-saving feature. For that to occur, you need to FIRST OC to 5ghz, and then apply C-States so that the CPU downclocks itself.

he, the OP , talked about "stock" settings. This is why i said NOT POSSIBLE. You cannot apply a 5Ghz overclock on transition idle-load UNLESS you actually OCed before.
 

Gregkar

Honorable
Dec 18, 2013
5
0
10,510
0
Yes.

1. Use adaptive voltage (not "Manual") to keep temps lower.

2. Make sure at least C-states C0-C2 are ENABLED; you may limit C-states to C2* (or disable C3, C6, C7, etc.) for faster transient response (so you won't be shutting down clocks or powering down cache).
*(Note: If you want the computer to be able to "Sleep", enable/limit to C3).

3. Make sure you're not running Windows 10's "Performance" power plan. You can edit the "Balanced" plan to use all of the "Performance" plan's settings (except "Minimum Processor state, which you can set as low as 20%), but (at least in b1909) even when you drop "Minimum Processor" under the "Performance" plan, it pegs it at a constant 100% — (apparently disables Windows 10's driver support for Intel's "Speed Shift").
Thanx a lot! that worked! i still get the same temps though.. maybe it's time for new thermal paste? it's been 2.5 years
 

ASK THE COMMUNITY

TRENDING THREADS