How to remove write protection on generic usb disk drive

Page 2 - Seeking answers? Join the Tom's Hardware community: where nearly two million members share solutions and discuss the latest tech.
Status
Not open for further replies.

howlinwoofer

Reputable
Oct 11, 2014
1
0
4,510
0
Thanks to wiseman378 for the "diskpart" solution however I have found this to be a temporary fix. Somehow, my external drive becomes write protected again and I redo the "diskpart" script. It defeats trying to run auto backups. Anyone have a permanent fix?
 

Mattfreestyle13

Reputable
Oct 16, 2014
1
0
4,510
0


type in: list volume after you get to diskpart
 

Dynamites

Reputable
Oct 26, 2014
1
0
4,510
0

I tried this but didnt work, after the attributes disk clear readonly step i got the message "Disk attributes cleared successfully." My flash drive was still write protected afterwards though
 

Gbenga Famodun

Reputable
Nov 12, 2014
1
0
4,510
0

thank you it work
 

wizardaks

Reputable
Dec 8, 2014
2
0
4,510
0
this has solved my problem.... tnx
\


Method 3 of 7: Adjusting the Registry (Windows)
1Understand the risks. Windows operating systems have a "registry" which contains a great deal of important information. An error here could be making all memory cards and USB drives read-only. While the steps below will safely locate and correct this problem if present, do not change any other settings inside the registry editor, or you could make your operating system unusable.
Backing up your registry is recommended before editing it.
Disable Write Protection Step 2 Version 2.jpg
2Open the registry editor. You can access the registry editor by entering regedit into the Search field in your Start menu. Windows 8 users can type regedit when viewing the Start screen. Press enter on your keyboard to search, then open "Registry Editor" when it appears.
If you can't find it, try searching for registry error or registry errors instead.
Disable Write Protection Step 3 Version 2.jpg
3Navigate to HKEY_LOCAL_MACHINE. This folder can be found in the Computer section of the registry editor, in the left frame. Click the arrow next to HKEY_LOCAL_MACHINE to expand the folder.
4Navigate to the correct folder. Inside the HKEY_LOCAL_MACHINE, find and open the SYSTEM folder, then CurrentControlSet, then Control. Finally, scroll down until you find the StorageDevicePolicies folder. If this folder does not exist, see the next step.
Disable Write Protection Step 5 Version 2.jpg
5Create the StorageDevicePolicies folder if it doesn’t exist. If you cannot find the StorageDevicePolicies folder, then you will need to create one before continuing. Right-click in the blank space in the Control folder. Select New, and then Key. Label it StorageDevicePolicies without spaces, exactly as shown here.
Disable Write Protection Step 4 Version 2.jpg
6Change or create the "WriteProtect" entry to 0. Double click on the "WriteProtect" key in the StorageDevicePolicies folder. Change the “Value data” field from 1 to 0. Press OK. If you created a new StorageDevicePolicies folder, follow these steps instead:
Open the new StorageDevicePolicies folder, then right-click in a blank space. Select New, and then DWORD (32-bit) value. Name the new file WriteProtect. Double-click WriteProtect to open it, and put 0 in the value field. Press OK.
You must type each entry exactly, including capitalization, otherwise the key will not work.
Disable Write Protection Step 6 Version 2.jpg
7Reboot your computer. In order for the registry changes to take effect, you will need to reboot your computer. Save all of your work before rebooting.
 

wizardaks

Reputable
Dec 8, 2014
2
0
4,510
0
Method 3 of 7: Adjusting the Registry (Windows)
1Understand the risks. Windows operating systems have a "registry" which contains a great deal of important information. An error here could be making all memory cards and USB drives read-only. While the steps below will safely locate and correct this problem if present, do not change any other settings inside the registry editor, or you could make your operating system unusable.
Backing up your registry is recommended before editing it.
Disable Write Protection Step 2 Version 2.jpg
2Open the registry editor. You can access the registry editor by entering regedit into the Search field in your Start menu. Windows 8 users can type regedit when viewing the Start screen. Press enter on your keyboard to search, then open "Registry Editor" when it appears.
If you can't find it, try searching for registry error or registry errors instead.
Disable Write Protection Step 3 Version 2.jpg
3Navigate to HKEY_LOCAL_MACHINE. This folder can be found in the Computer section of the registry editor, in the left frame. Click the arrow next to HKEY_LOCAL_MACHINE to expand the folder.
4Navigate to the correct folder. Inside the HKEY_LOCAL_MACHINE, find and open the SYSTEM folder, then CurrentControlSet, then Control. Finally, scroll down until you find the StorageDevicePolicies folder. If this folder does not exist, see the next step.
Disable Write Protection Step 5 Version 2.jpg
5Create the StorageDevicePolicies folder if it doesn’t exist. If you cannot find the StorageDevicePolicies folder, then you will need to create one before continuing. Right-click in the blank space in the Control folder. Select New, and then Key. Label it StorageDevicePolicies without spaces, exactly as shown here.
Disable Write Protection Step 4 Version 2.jpg
6Change or create the "WriteProtect" entry to 0. Double click on the "WriteProtect" key in the StorageDevicePolicies folder. Change the “Value data” field from 1 to 0. Press OK. If you created a new StorageDevicePolicies folder, follow these steps instead:
Open the new StorageDevicePolicies folder, then right-click in a blank space. Select New, and then DWORD (32-bit) value. Name the new file WriteProtect. Double-click WriteProtect to open it, and put 0 in the value field. Press OK.
You must type each entry exactly, including capitalization, otherwise the key will not work.
Disable Write Protection Step 6 Version 2.jpg
7Reboot your computer. In order for the registry changes to take effect, you will need to reboot your computer. Save all of your work before rebooting.
 

Agi Egia

Reputable
Jan 31, 2015
1
0
4,510
0
go to properties of the device -> sharing -> advanced sharing -> permission -> check all the tickbox -> apply/ok. this work for me
 

chaungochan1107

Reputable
Feb 6, 2015
1
0
4,510
0
I have found an old solution that worked on my 64 gig USB drive. No need to modify registry or download software. Try this system fix:
Open a command prompt
type DISKPART press <enter>
type LIST VOLUME press <enter>
type SELECT VOLUME X, where X is the volume number you want to remove the write protect from. In my case is was Volume 6
type ATTRIBTES DISK CLEAR READONLY press <enter>
you will see a prompt that the write protect has been removed
type EXIT press <enter>

Good luck!

This work for me. To the people whose USB are still write-protected after having done this, try unplug the USB and plug it in again.
 

lykouse2012

Reputable
Feb 24, 2015
1
0
4,510
0

This fix has acctualy made my thumb drive useless. System no longer reconizes it '


 

Dre Konrad

Reputable
Apr 8, 2015
1
0
4,510
0
Right click the drive
> Properties
> Sharing
> Advanced Sharing
> check Share This Folder
> Permissions
> check Full Control under Allow column
 

David_262

Commendable
Mar 14, 2016
1
0
1,510
0


Its says disk attributes cleared succesfully. I stil cant format the disk becuase it has the write protection.
 

Rodrigo_666

Commendable
Apr 26, 2016
1
0
1,510
0
I tryed all this steps and still can't format, same thing happens!



 

hadron

Commendable
May 13, 2016
3
0
1,510
0
Go to http://us.apacer.com/support/download/result/3,8,0 and choose "USB3.0 Repair tool"). Download it and unzip the file.

- Connect the usb stick with your pc

- Click "Restore.exe"

- Click "Restore"

- Click again on "Restore"

- You will see "Are you sure you want to continue?". Click "yes"

- Now you will see "Restoring Device", wait till the program finish his job

- After that you will see "Restore Completed" en "Please replug device before use", click on "OK", unplug the stick and put it back again in your pc.
 

Joven_1

Commendable
Jun 13, 2016
1
0
1,510
0


 

apamular

Reputable
Aug 4, 2015
4
0
4,520
1


YOU SAVED ME FROM THROWING MY USB YOUR THE MAN!!! all other fix did not work.
 

hadron

Commendable
May 13, 2016
3
0
1,510
0


You welcome. I'm glad it worked!

The usb stick will return to the factory settings, probably in exFAT. In that case, you can't copy large files to the stick, so you have to format it to NTFS.


 

Mitko25

Commendable
Jul 25, 2016
17
0
1,510
0



Hey, i have the same problem but when i try your solution it doesn't remove write protection. Can you please help we!
 

timtak

Honorable
Sep 29, 2016
15
1
10,515
0


Thank you. That allowed me to format my disk. It was scary because the utility does not tell you which disk it is about to format. I was scared it would format my system disk, but it did format my only USB drive on G:.

The utility crashed part way (perhaps because my disk was from Verbatim not Apacer) but afterwards I was able to use the usual Windows format utility which I had not been able to use before since the disk was write protected.

I have a new 128GB disk on order but until that arrives I can keep using my USB 3.0 disk.

 

Bogdanovicis

Commendable
Oct 10, 2016
1
0
1,510
0






Thanks man. You saved my usb. I was ready to throw it away. all the other things didn`t work. It failed so many times that i didn`t believe anymore that is gonna be solved. Thanks again.
For the others, use this method with fully trust.
 

Dolphinebabe

Reputable
Feb 19, 2015
4
0
4,510
0


 

Dolphinebabe

Reputable
Feb 19, 2015
4
0
4,510
0


 
Status
Not open for further replies.

ASK THE COMMUNITY