How to share a folder only with specific people on your network?

Nils

Distinguished
Aug 7, 2008
586
0
19,010
10
Hi,

I'm having a bit of trouble with this. I have both a laptop and desktop computer and I like to set up file synchronization between both. Therefore I'd like to share my documents folder on the laptop with full permissions with my desktop computer only (and not with all other users on the network ofcourse).
How can I do this? Both PC's have different computer names but the same user account name. I already tried out the Share->with specific users and Advanced Sharing option without succes.
Any help on this would really be appreciated.

Thanks

Nils
 

nukemaster

Titan
Moderator
Nov 23, 2004
19,633
0
81,160
2,279
When you share the folder with your login name setup as the only one to have access, you also have to make sure the NTFS permissions match.

You HAVE to have your user name, not just the administrators group since Windows 7 does not make you admin until the UAC prompt is accepted. This was a big change from XP when your user was an admin(this was done for users own safety).

You NEED both share and NTFS permissions to work. If the share permissions are set and the NTFS are not, you will have issues.

Please note that if you delete a file the other computer on the network, it will NOT goto the recycling bin. So take care when removing files.

If you make that your document location with windows, files "should" goto the recycling bin on the second(works for my desktop) computer, but no promises.
 

Nils

Distinguished
Aug 7, 2008
586
0
19,010
10
The problem with Advanced Sharing is that it seems impossible to specify the computer you want to share to. It only allows to specify user names on the computer you're working on. So in my case I'd like to specify DESKTOP_PC\My_account as a location to share to, but the only thing I can specify is LAPTOP_PC\My_account.
 

noidea_77

Distinguished
Jul 28, 2012
6,528
0
19,960
778
It's actually COMPUTER_NAME_SHARING_FROM\ACCOUNT_NAME_SHARING_FROM. The full account name on the network always is computer_name+user_name. Might be confusing, because you have the same account name on both machines.
 

nukemaster

Titan
Moderator
Nov 23, 2004
19,633
0
81,160
2,279
If you have the same account name on both computers, It will work just fine as long as both sets of permissions are set right.

This is how my dekstop(and some other folders) on 2 of my systems has been setup.

I did nothing but use my username on both systems(user name and password). since they match it all works without any issues.

Now if you have different user names, you can make your self a limited user(standard user) to match(on the sharing machine), just do not log into it and it will not create its own folders. That users login and password can match the computer connecting and it will work as well. Again, after this you have to setup the share + ntfs permissions.
 

Nils

Distinguished
Aug 7, 2008
586
0
19,010
10
Are there any specific settings I have to make in Advanced Sharing Settings in Control Panel? Like password protected sharing and so on?
 

nukemaster

Titan
Moderator
Nov 23, 2004
19,633
0
81,160
2,279
If you turn off password protected(I leave mine on so only 2 computers can see it. I have the account[2 different ones] for both on here so those 2 systems never need to enter a password since it matches) sharing anyone can see the shares, but should still require a password to access them if they are not shared with "everyone"

Are the log-ins on both pc's the same are they both one Windows 7? any more details so I can help you better.

Can i get a screen of your share + ntfs permissions for the folder in question.
 

Nils

Distinguished
Aug 7, 2008
586
0
19,010
10
Okay so I finally got this working the way I want it to :) These are the things I did.

1) disable password protected sharing so every computer can access my laptop and see my shares (I have no problem with that)
2) The files I want to share to my desktop only, I share under my account name. Files I want to share with everyone I share under Everyone.
3) Now here's the thing. In the Security tab I had to add an entry Everyone with the correct permissions, otherwise nobody could access the files. Problem is I have to do this with every folder I want to share with everyone. So is there a possibility to add Everyone as a standard entry to that list, like Administrators etc. already are?
 

nukemaster

Titan
Moderator
Nov 23, 2004
19,633
0
81,160
2,279
Yes, you can add everyone then force it to share with subfolders.

Just get to the "Security tab", then select "Advances" then "Changer Permissions".
Now set everything the way you want it to be(do not remove anything, just add your everyone with "read & execute" if needed).
Now use the "Replace all child object permissions with inheritable permissions from this object" box to force things.


You can go as far as to do this to the entire drive if you wish(this will allow anyone who has physical access to the drive of share level access to READ, but if set right, not write to the drive or delete files.). You may get some errors about special folders, but don't worry.

Please note if a folder is set NOT to inherit permissions it will not get the changes(those folders are far and few between).
 

Similar threads