How to stop fluctuating frame rates?

CheekBoys

Honorable
Oct 12, 2013
167
0
10,680
0
Is there a way to control frame rates so they are not fluctuating from 30-60 constantly? Or is there a way to lock the frame rate to 35 without screen tearing? I tried using evga precision x but there is a lot of screen tearing even with v sync on.
 

getochkn

Titan
Moderator
Jul 2, 2006
12,212
0
71,160
2,340
Frame rates go up and down depending on what's going on in the scene. If you want it locked at 60 or 120 or whatever vsync your monitor is, you need a really good gpu/cpu. With vsyncing, it drops any frames over 60, but if one second dips belows 60, it can have tearing. I think NVidia has adaptive vsync that is supposed to make up for that.
 

CheekBoys

Honorable
Oct 12, 2013
167
0
10,680
0

Is there a way to do that without screen tearing?
 

getochkn

Titan
Moderator
Jul 2, 2006
12,212
0
71,160
2,340
also what game, what video card, what screen? are you using a tv instead of a monitor? could be lots of things.
 

bystander

Polypheme
Dec 9, 2009
15,122
0
61,160
1,008


If you get 30-60 FPS in all games, and do not want the fluctuations or tearing:
1) Turn on V-sync
2a) Set a FPS limiter to 30. It may cause lag, but at the settings you have, that is all you can do.
2b) Turn down graphical settings until it no longer fluctuates.
2c) If you still cannot reach your goal, a hardware upgrade may be needed.


In a few months or so, G-sync may be available with the right monitor that will allow for a much better method to remove tearing.
 

CheekBoys

Honorable
Oct 12, 2013
167
0
10,680
0

Even if the game runs at 60 fps consistantly, if I turn the frame limiter to 30fps with v-sync on it still has screen tearing.
 

bystander

Polypheme
Dec 9, 2009
15,122
0
61,160
1,008


If you get tearing, v-sync is not functioning.

Either the game is not allowing it, or you do not have something set properly. What program are you using to limit FPS or turn on Vsync?
 

CheekBoys

Honorable
Oct 12, 2013
167
0
10,680
0
I have tried using v sync on inspector and the game but neither work. I have the frame rate limiter set to 35 fps.
 

bystander

Polypheme
Dec 9, 2009
15,122
0
61,160
1,008


What game?

You may also have adaptive v-sync enabled in the Nvidia control panel, which would override any options you choose elsewhere.
 

CheekBoys

Honorable
Oct 12, 2013
167
0
10,680
0

I have mostly tried Assassin's Creed 4 and Batman: Arkham Asylum. I am thinking since the refresh rate is still 60 hz but it is only showing 35 frames per second maybe that is the reason for the tearing.
 

bystander

Polypheme
Dec 9, 2009
15,122
0
61,160
1,008


That is not a reason for tearing. Go to your Nvidia Control Panel 3D settings, and make sure you are not forcing v-sync off, or adaptive v-sync on.
 

CheekBoys

Honorable
Oct 12, 2013
167
0
10,680
0

I have it forced on. The screen tearing isn't as noticable as normal but there is tons of small tears all around the screen.

 

bystander

Polypheme
Dec 9, 2009
15,122
0
61,160
1,008


Which V-sync option do you have selected? (normal v-sync, adaptive v-sync, or adaptive v-sync (half refresh))?

If V-sync made a noticeable difference, but you are now seeing "small tears" around the screen, perhaps this isn't tearing at all.

What are "small tears". A tear will always be a single line across the screen. It may be on one single horizontal line, or broken into two lines, but either way, it is a single line that spans the whole screen, without exception.

What are you seeing with these "small tears"? When do these tears occur?
 

CheekBoys

Honorable
Oct 12, 2013
167
0
10,680
0

I just have "force on" enabled. I have a video that is processing I will post it when it is done.
 

CheekBoys

Honorable
Oct 12, 2013
167
0
10,680
0
The video isn't uploading but what it looks like is a lot of tiny horizontal lines across the whole screen just like normal tearing but not as noticeable.
 

bystander

Polypheme
Dec 9, 2009
15,122
0
61,160
1,008



What are you doing when it happens?

Does it happen when you are not moving the camera view?

Do you see more than one on the screen at once?
 

CheekBoys

Honorable
Oct 12, 2013
167
0
10,680
0
I see it when I move the camera and it seems like there is only 1 on the screen at a time but they are so fast and subtle it is hard to tell.
 

bystander

Polypheme
Dec 9, 2009
15,122
0
61,160
1,008
I don't know why v-sync isn't working for you, but that does sound like normal tearing. V-sync is not functioning by your description.

You can try to turn off the forced v-sync option from in the game panel and use the in game v-sync option by itself.

You may try to reinstall the latest drivers.

Did you say tearing does not occur without the FPS limiter on? Perhaps the limiter you are using is interfering. See if you can find another FPS limiter.

Do you have multiple monitors? In some situations, multiple monitors messes with v-sync.
 

bystander

Polypheme
Dec 9, 2009
15,122
0
61,160
1,008
Btw, what is your monitor?

I tested out the scenario you gave, and it worked fine for me. It was very choppy, but there was no tearing. I used EVGA Precision X instead of MSI Afterburner (they are both built from rivatuner). I could not find the FPS limiter in MSI afterburner, except for video capture.

I did occur to me that if you have a slow monitor, the refreshes are quite slow to update. Slow enough that when spinning fast, you can see it sort of tear due to how long it takes for your monitor to update the image.

Did you say it was improved than without v-sync?

Back when I used a 60hz monitor (I use a 120hz monitor), spinning fast did result in seeing odd artifacts, possibly tearing like.

 

CheekBoys

Honorable
Oct 12, 2013
167
0
10,680
0
I fixed it! I tried using Bandicam to limit the frame rate to 35 with v sync on and it worked :D Thanks for the help.
 

bystander

Polypheme
Dec 9, 2009
15,122
0
61,160
1,008
You may also try EVGA Precision X. I've heard the MSI Afterburner option is only there for AMD. I can't find the option with an Nvidia card.

Anyways, great to see it is fixed. Apparently that MSI Afterburner option does not work well with Nvidia.

You may also want to play around with different FPS limits. You may find 30 FPS is smoother than 35.
 

CheekBoys

Honorable
Oct 12, 2013
167
0
10,680
0
I have tried MSI Afterburner and Precision x before with the same tearing as anything else.

 

Similar threads