Question How to stop Ryzen 2200g from underclocking itself under load?

Jan 27, 2019
3
0
10
0
While I'm gaming the usage of each core would constantly erratically jump from 60% to 80% or even 100% and then back to 60% In less than a second. This is normal in a game. However, at the same time the processor underclocks and overclocks itself accordingly to the usage and these changes cause stuttering which is particularly noticeable there's an explosion because usage goes up all of the sudden and the underclocked processor can't handle the sudden demand.

I have tried everything in the bios and in Windows to lock the CPU frequency to the advertised 3.5 or at least make it never underclocked itself but so far the only thing that works is manually over clocking the frequency. I've set it to 3.525 and changed nothing else and that sometimes causes BSODs.

I seem to be stuck either with annoying stuttering or occasional blue screens. Locking the frequency to 3.525 really fixes the stuttering but how do I disable the processor's power saving features? I have disabled C states, enabled full phase mode, set my power plan to high but unless I overclock the processor, it runs demanding games at 2.8 Mhz and craps itself when all of a sudden something big happens on the screen.

A particular offender is Ghost Recon Wildlands: that game is so terribly optimized that in the benchmark at 50% CPU usage and 60% GPU usage it could barely maintain 60 fps and constantly fluctuated down to 30-40fps. The stuttering made the game unplayable. But when I locked the frequency at 3.52 the game ran at smooth 60 fps with only a single drop to 54. What I think happened here was, the CPU responded to the low usage by underclocking itself, thus further reducing the performance of the already badly optimised game. It is so stupid that this is happening.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS