[SOLVED] How to switch from Intel integrated graphics to dedicated GPU?

Status
Not open for further replies.
Jun 21, 2019
5
1
20
1
To preface:

-This is a laptop with a 1660ti and Intel 630 graphics
-When I try to run some games, the 630 is used over the 1660ti
-Nvidia Control Panel doesn't work, saying that the "Application is not compatible with the installed Nvidia driver"
-When I try to update the Nvidia drivers with Geforce Experience it says that it's unable to install the driver
-In device manager the 1660ti has an issue saying "A driver (service) for this device has been disabled. An alternative driver may be providing this functionality. (Code 32)"

I think that the intel drivers are somehow interfering with the nvidia drivers, but I'm not sure if uninstalling them will affect the system too much. Also if I disable the integrated graphics temporarily, the resolution of this laptop drops significantly.

Thanks for any help
 
Jun 21, 2019
5
1
20
1
stick with 1 thread
I had an issue with the integrated Intel 630 graphics overriding the 1660ti I have, after uninstalling the drivers for the 1660ti, it's no longer recognized. I tried reinstalling the drivers, but now only "Microsoft Basic Display Adapter" is displayed when before it had 1660ti listed.

Before this with the 1660ti there was an error that said "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)" and now in addition it says "
The driver trying to start is not the same as the driver for the POSTed display adapter."

At this point would it be worth just factory resetting the laptop? Would this even solve the issue?

When trying to access either nvidia geforce experience or nvidia control panel, both would not work stating errors with the current driver version or in the case of geforce experience, just not working.

Please help!
 
Jun 21, 2019
5
1
20
1
Ok I've solved the issue. Here's what I did:

I got DDU installed and the drivers for the 1660ti from the Acer website. I booted into safe mode and using DDU, I uninstalled the drivers. Then I installed the 1660ti drivers and it was recognized by device manager without any issues. Thanks everyone for help!
 
Reactions: Captaingadget
Status
Not open for further replies.

ASK THE COMMUNITY