Question HP Envy M6 laptop (m6-n113dx) Screen opens and closes random windows on its own and goes crazy

JVM1120

Honorable
Aug 12, 2016
9
1
10,515
0
I have an HP Envy M6 laptop I have been having problems with that makes it almost unusable. After using the laptop for awhile my screen goes crazy and starts closing windows and reopening them, clicking all over. It's like the laptop has a mind of its own sometimes. I have to restart the computer to get it to stop. I have a touchscreen on this laptop so I'm not sure if that could be causing the issue or something with the trackpad. Its almost like the pointer is getting stuck.

I originally thought it might be a virus and ran scans on the computer and in safe mode to be sure and it came back clean. I did a clean install of Windows 10 and upgraded the hard drive to an ssd drive, I upgraded the memory to 16 gb, and updated anything I could. I tried just about anything I could to try and fix it with no luck. Its one of the reasons I upgraded to a new laptop. It would be nice to have a second laptop and thought maybe someone on here could give it a go and help me.

I took a quick video of the laptop earlier today before I factory reset the laptop again. Apologies for the low quality and glare but you get the idea of what I'm talking about.




HP ENVY M6 ( m6-n113dx)
Windows 10 Home 64 bit Pro
AMD FX-7500 Radeon 2.10 ghz
16.00 GB Ram
256 GB Crucial SD Drive
 
Touch screen is bunk seen it many times.

You can disable the touch screen in device manager under

  1. Press the Windows key + X.
  2. Select Device Manager from the list.
  3. Click the little arrow next to Human Interface Devices to expand the list.
  4. Click the touch screen driver.
  5. Right-click, and select Disable from the list.
  6. Click Yes on the dialog box.
 

JVM1120

Honorable
Aug 12, 2016
9
1
10,515
0
Touch screen is bunk seen it many times.

You can disable the touch screen in device manager under

  1. Press the Windows key + X.
  2. Select Device Manager from the list.
  3. Click the little arrow next to Human Interface Devices to expand the list.
  4. Click the touch screen driver.
  5. Right-click, and select Disable from the list.
  6. Click Yes on the dialog box.
In the device manager it only has two options under Human Interface Devices:

HID-Compliant wireless radio controls
HP Wireless Button Driver

would it be listed somewhere else? or am I missing something?
 

ASK THE COMMUNITY