Question HP no POST


Mar 7, 2018
I've seen a lot of weird things in my time, but none quite this strange. I'm working with an HP Pro 3500. It doesn't POST immediately, and sometimes not at all.
What I've tried:

Re-seating and swapping memory - used known-good RAM
changed CMOS battery and checked voltage - reading 3.17V
used jumpers to reset bios setting
Removed all peripherals, including all PCI, SATA, USB, and Ethernet connections
Swapped PSU with known good and brand-new unit
Re-seat CPU and visual inspection of CPU pins/pads

Like I said, I was able to get POST sometimes, at which point I tweaked the following in BIOS:
Disabled UEFI, booting only to legacy System Rescue CD USB live installation
disable all security (There were no BIOS or HDD passwords to begin with)
set time/date

The behavior of the machine: the fans spin, but POST never shows. Resetting, sometimes upwards of 4-5 times, I might get POST, and then boot behavior is typical. This requires a physical human to be in the room, which is not ideal. This is a remote machine and rarely touch by human hands. I've visually inspected the board looking for blown components, cracked fets/swollen caps. Nothing really jumped out at me there. I'm thinking the mobo is toast, but I still get POST - only sometimes.

Any clues? Where to look next?

The user manual for those interested: