HP OfficeJet 7310 -- Installation looping problem



Archived from groups: comp.sys.hp.hardware (More info?)

Hello -- I have been supporting a client with a home office. He has
just purchased an HP OfficeJet 7310...


....and it is connected to his home network (through a D-Link cable/DSL
router); not connecting through USB. Te computer being used is an
HP/Compaq NC8000 (2.0GHz/512MB/60GB HDD) running Windows XP with SP-2
and Symantec AntiVirus Corporate Edition.

The router has assigned an IP address to the printer. Also, the
printer is pingable by IP, built-in web server (to access status and
configuration functions) is accessible through IE.

PROBLEM -- The driver/software installation will not proceed past the
step where it is about to actually copy/install drivers and software.
I can get through the follwoing steps: (1) installation software
prompts to select direct (USB) connection or network connection
(network is selected); (2) searches and correctly identifies the
printer on the network (returns MAC and I address); (3) option of
automatic or manual TCP/IP settings (auto selected). Click next to
begin the installation and the install software instantly jumps back to
step (1) above. This is instant -- no hour glass, no errors, no events
logged in Event Viewer. I have even tried connecting the computer
directly to the printer via a network cable -- this behavior persists.
I cannot get past this step.

Has anyone experienced this same problem?

I telephoned HP Support and they insist that this is a firewall issue
with the router. When I informed them that the printer is clearly
viewable through the home network and the installation problem occurs
when the computer is connected directly to the printer, they said it
must be the Windows Firewall or the anti-virus software. To my
knowledge SAV Corp. has no "firewall" functions, but SAV has been
disabled for all installation attempts. I have tried with the Windows
Firewall turned off and even with the Windows Firewall Service stopped
-- problem persists. Even ran installation from copy of CD contents on
C: -- still no luck.

Suggestions? Solutions?

Thank you,

Mark T.


Archived from groups: comp.sys.hp.hardware (More info?)

To resolve the issue, install the software using an adhoc network
between the printer and the computer, then continue with the
installation as usual. After the installing the software, change the
settings to infrastructure mode and it will work.