Question HP Probook 6450b won't turn on

el-aasi

Reputable
Aug 30, 2015
11
0
4,510
0
Hello everyone,

I have a little issue with my old laptop. I will try to keep it as short as possible at the same time not to omit important info.

I have a Probook 6450b for quite a few years, for 3 years or so I haven't used it at all but lately (4 months) I started using it as a server, just to experiment. When I started it after the 3 years I saw that a warning popped up about the battery.

I did not pay much attention as it would be only stationary, basically running 24/7 with Ubuntu server on it.

All good, now at some point last week I wanted to change its location, so turn it off, change the position turned on back. After a few seconds, it dies, tried again, dies again, when tried fourth time saw that it doesn't show a power cable plugged in.

The power adapter and battery were changed (on the spec shows 19v output) back when I was using the laptop (used both of them for a year or so before getting the new laptop).

Now without the cable (with battery) when power on, nothing happens. When plug in the cable the power LED lights blue (white) for half second than orange.

When I try to power on 8 times (sometimes 10) orange LED blinks then nothing. Tried the 8-step guide, nothing, opened it up removed the small CMOS battery, checked it and it was dead so replaced it.

Nothing....so I am out of options :)) anyone any ideas? It's not a priority to fix it, as I don't really use it much...so I am not going to take it to the repair shop, but out of curiosity (and respect for the laptop) I don't want to give up on it before I try everything.

So....long post, sorry.
 

el-aasi

Reputable
Aug 30, 2015
11
0
4,510
0
Most likely thing is a bad motherboard. Remove the ram and the disk drive, try turning it on, do you get error beeps or error lights? If not, then motherboard is first thing to check.
Hi,
I have completely disassembled the laptop to check the dc output on the power socket (dc jack) I can see a difference in reading (from the adapter 19.65 V from the dc jack on the mobo 18.5 V) I will assemble it back now, and try your suggestion see how it goes, otherwise will try to put a new jack in and see how it goes

Thank for the reply!
 

el-aasi

Reputable
Aug 30, 2015
11
0
4,510
0
Most likely thing is a bad motherboard. Remove the ram and the disk drive, try turning it on, do you get error beeps or error lights? If not, then motherboard is first thing to check.
just put it back, same shit 8, sometimes 10 orange blinks... I need tho to find a proper battery to try with that before I give up on it
 

ASK THE COMMUNITY