Aug 14, 2019
31
9
35
0
So, I recently built a new 'gaming' pc featuring a Ryzen 5 2600X and a Zotac RTX 2060. After finishing my build and installing Windows 10, I began experimenting with various bios and Windows settings in order to optimize my system for gaming and push my 2600X/RTX 2060 to their fullest potential. I experimented with everything from overclocking my CPU and RAM, to various Precision Boost Overdrive and Load-Line Calibration settings and I even ran tests on all available Windows power plans.

Everything was looking and feeling great and I was very happy with the performance I was seeing in my benchmarks. So, after a few days of honing in on the best possible setup for my new system, I figured it was time to start putting it to the test. So, I transferred a few of my favorite games from my old system to my new one and immediately launched Call of Duty: Black Ops 4. I was impressed with how quickly the game launched and loaded on my new system and was really looking forward to finally using my 144hz Acer monitor to its' fullest potential by getting a steady 144fps in-game.

However, when I eventually got into a match (after fine tuning the in-game settings) I immediately could tell something wasn't right. The movements felt sluggish and choppy, the frame time felt like it was bouncing all over the place and I would instantly get HUGE frame drops and horrible input lag any time I was engaging an enemy player. I know the phrase "this game is unplayable" has been overused and has lost some of its' validity. But believe me, when I say BO4 was 'unplayable' in that state, I mean it was 100% truly not playable. So, I quickly backed out of the lobby and quit back to the Windows desktop, confused over what the $#@% I had just experienced. I restarted the computer and tried again. Still unplayable. Tried resetting my bios to default...that didn't work. I removed the slight overclock that I had applied to my RTX 2060 and reset my nvidia control panel. Still nothing changed.

I literally sat at my PC for the next 2 or 3 days tweaking and retesting my game trying to figure out what the hell I could've possibly done wrong. Then it hit me...I remembered hearing some random YouTuber talking about High Precision Event Timer (HPET) and how it could have a negative effect on some Ryzen chips, especially when gaming. So, I opened up my device manager, scrolled down to System Devices and disabled HPET. I also opened up Command Prompt and ran a quick command to make sure HPET was completely disabled on my system. Lastly, I went into my bios and checked every last option to make sure it wasn't also enabled in my bios settings.

Once I was finished disabling HPET and was sure there were no traces of it left on my system, I launched Black Ops 4 and crossed my fingers...and well...IT WORKED! After days of tweaking and testing and re-tweaking and re-testing I finally found the culprit. HPET. Now, why does HPET cause some Ryzen chips to go haywire? I honestly don't know exaclty, but I would assume it has something to do with how Windows schedules tasks? Or possibly something to do with how Windows handles multi-threading? I'm not sure... But either way, the bottom line is, disabling HPET on my particular system helped greatly with frame rates, micro stutters, lag and overall performance (especially in games!).

So, if you've built a Ryzen system and can't seem to figure out what on earth is causing you experience lag, stuttering and overall crappy performance, then disabling HPET may be something to try. It is easy to disable and even if HPET isn't your problem, it is also easy to re-enable. Anyway...hope this helps someone! Good luck and if you have had any personal experience with HPET effecting your Ryzen build, please let me know.

Information on HPET and a Guide on how to disable/enable it:
 
Reactions: DMAN999

ASK THE COMMUNITY

TRENDING THREADS

Latest posts