• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!
Aug 4, 2019
3
0
10
0
So, i turned on my pc one day after holidays (changed ram) and the screen kept freezing after i logged in or even before the lock screen. So i thought it was a gpu issue and changed gpu to a cheap gpu. And it worked but after like 10 mins of working either the screen would go fuzzy like a tv with no signal, or it would freeze in screen saver or my peripherals would lose power. so i chose to use integrated graphics and same issued happened, so i tried changing ram, same issue, i tried changing a cpu still same issue. so things i have changed to see if works: ram, cpu, gpu, vga/dvi cord, monitor. and same issue with the lot. I dont know why i lose power with my peripherals.
Pc Specs:
Cpu: I3 2100 and I3 2105 as back up
Gpu: 560ti a cheaper one that works and integrated graphics
Ram: 8gb stick DDR3 and 4-2gb sticks DDR3 ranged from 1333mhz-1600mhz
Hard Drive: 1.5 TB
Motherboard: MS-7728
PSU: Corsair VS450 (new used for about 3 weeks)
Please Help...
 
Aug 4, 2019
3
0
10
0
Ok, so when i went into bios literally straight away got a fuzzy screen (like when a tv gets no signal) and every-time i go into bios it does it. its a different patterned fuzzy screen
 
Sep 15, 2019
85
8
65
8
Might be that your power supply might have gone bad or the motherboard is failing. Try changing that Powersupply, if it still doesnt work than might be that the VRM's in your motheboard are falling.
 

ASK THE COMMUNITY

TRENDING THREADS