Question HWMonitior, Speccy, and CPUID issues

DougEFresh333

Commendable
Jan 19, 2017
33
0
1,530
0
HWMonitor is no longer showing ANY reading, it just shows the name of my PC. CPUID gets stuck at 2% when loading, and then fails with a "Mutex locked" error, then opens but does not display anything. Speccy also opens, and shows some info, but CPU, RAM, Motherboard, and GPU, reading simply say "cannot load SPC DLL". any ideas WTH is happening? everything read fine a few days ago, and always has, but now, nada. Precision XOC shows all the correct readings, Core Temp also shows the correct readings. and GPU-Z also shows readings, so i'm not entirely sure what the problem is. Things are obviously working properly if other software can read the sensors, so what is going on with the CPUID and Speccy software??? it wasn't a windows update, or any other kind of update that caused this. the power went out in our house a day or two before i noticed that the readings were not appearing, but i have a battery back up, so i was able to power down normally, i just lost my internet connection before i shut down. can anyone help me figure out what happened?

System running with: Windows 10 Pro, Asus Maximus X Hero, I7 8700k, EVGA GTX 1080 TI, 32 GB RAM, on Samsung 960 Pro M.2 (with other hard drives for storage).
 

DougEFresh333

Commendable
Jan 19, 2017
33
0
1,530
0
well, after three days of wondering what the heck was going on. i did ANOTHER restart on my PC, after using CCleaner to clear the cache and registry, and ran Malawarebytes, and restarted two days after that, and now suddenly, all three softwares (HWMonitor, CPU-Z, and Speccy) are all reading everything properly. so if anyone ever has any issues with this, run the registry cleaner, clear the cache, and restart your PC. although i had already restarted, i believe it was clearing the registry issues, and THEN restarting is what did it.
 

ASK THE COMMUNITY

TRENDING THREADS