Question I am having a bizzare issue with windows 10 deleting itself from my SSD after a crash or a restart. Please help.

Nov 23, 2020
19
0
10
0
I will try to explain in as much detail as possible.

Two days ago I got a new motherboard Asus Rog strix E x570 along with new ryzen 7 5800x processor. I used my old Gigabyte 250gb for fresh installation.

I used a usb flash disk for fresh windows 10 install. Steps I took before installation.

Disabled launch CSM in bios.
In boot/secure boost set OS to windows UEFI
Made sure my ssd is in gpt format.

Installed windows successfull following these steps. Worked great for few hours. Then crash. SSD completely disappears from boot menu in bios. However, it continues to show under storage information. I check if connection is loose. Everything is ok.

I use my usb to get into installation again. To my surprise. My ssd is wiped clean along with my second hard disk. Its sitting there with free 250 gb again. I didn't even have to format it for fresh installation. Everything gone on two hard disks. Can't run any kind of recovery and repair because there is no windows installation on my SSD. However, data on my third hard disk and my nvme is fine.

So I decide to install windows again. After installation I play games for couple of hours. I go to bed. Start up my computer next morning and it boots right into bios. SSD has disappeared again. Nothing to boot from. I use my usb for win installation. My ssd is wiped clean yet again along with my hard drive for second time. It's also sitting there wiped clean ready to be allocated and created into partition.

This whole process has happened three times in two days no matter what I do. I ran chkdsk with no errors and even used crystal disk info and it shows its 97% good. Used mini tool partition to check for bad sectors on my ssd and nothing came up. 0 errors.

I am pulling my hair out because this is such a strange thing I am facing. What kind of error/fault can cause entire windows installation to disappear from my SSD not once but three times? And why the hell my second hard disk is getting wiped along with my main SSD? While my third hard disk and nvme are spared.

Can anyone explain please and help me out before I go out tomorrow and buy a new SSD. I don't know what else to do here. I am not a very technical person. I would really appreciate any help you can give me
 
Last edited:
Nov 23, 2020
19
0
10
0
Perhaps your SSD failed
That's what I am thinking. I am just confused because mini tool partition and crystal disk info shows my ssd is healthy and yet three times my system crashed after installation of new windows and wiped itself clean.

I have followed all the steps posted by Ralston so I know it's not the installation itself but what happens after installation that's making my head spin in frustration.
 

ASK THE COMMUNITY

TRENDING THREADS