Question I am having frame drops and stutter in YT videos

helper800

Distinguished
Aug 12, 2011
697
54
19,140
29
Since I have built this computer on the 7th of July I have been experiencing many dropped frames when watching Youtube videos on my 2nd 4k monitor. This frame dropping/stuttering happens regardless of what I am doing but is exacerbated when I drag my mouse cursor between monitors, move my cursor between the video and the comments section, and if I cause anything to load on the same tab.

Most of the videos I watch are in 60 fps as compared to the 30fps videos. I use Chrome as a browser. I have tried IE to watch the videos and although it does not show the frames are being dropped it has the same issues as with chrome. The problem persists with hardware acceleration on or off. Chrome is up to date, as is my BIOS, OS, and Drivers as far as I am aware. My PC specs are in the signature except for the PSU which is a Seasonic 850w PRIME Titanium.

I have tried googling this issues but can never get any of the solutions other people have found to work but I am willing to try anything within reason to get this fixed. Thanks a bunch in advance.
 
Last edited:

helper800

Distinguished
Aug 12, 2011
697
54
19,140
29
I have Google-Fu-ed a few more solutions to other people's problems that are close but not similar to mine. The things that I tried as they did are changing some settings in the Nvidia control panel.

The first change was to "Manage 3D settings" in the "Global settings" change the "Power management mode" to "Prefer maximum performance." This did not fix my particular issue but was worth a try. I am keeping this setting as it is now.

Second, under the "Adjust desktop size and position" change "Perform scaling on:" option to "GPU" for both the monitors. I also tried leaving it on "No scaling" as well. Neither fixed my issue no matter the combination of both suggested solutions.

Third, under the "Adjust video image settings" I set both "Edge enhancement, and Noise reduction" to "Use the NVIDIA setting" with +0%. I also enabled "Use inverse telecine." I enabled all the settings for both monitors, however, again there was no change to my issue.

Fourth, I changed the G-SYNC on my primary 1080p monitor to off with no change to my issue.

Fifth, I changed the 1080p monitors refresh rate to 120hz from 144hz under the "Change resolution" setting. This seemed to help a little but not solve my issue completely. I'd guess it helped the frame loss and stuttering when I drag my cursor between monitors by about 15-20%.

I would like some help with this issue. I am out of ideas and my Google-Fu is exhausted. I hope that others that see this post but have similar issues solve said issue with the above solutions or we find a solution to my specific issue.
 

helper800

Distinguished
Aug 12, 2011
697
54
19,140
29
Also what cables you used to connect the monitors and what GPU ports are you using. Did you try switching the ports.
Yes I did try switching cable ports on the card. I also tried HDMI instead of DP on my Samsung monitor. They are both connected via display port
Can you please list the system specs including monitors
All of my system specs are in my signature like I already said in the OP. Click my signature it says all my specs except my PSU which is a Seasonic 850w PRIME Titanium.
 
Are you using wired keyboard and mouse or a wireless ones. If using wireless try the wired. If using wired and still getting the problem with display frequency lowered to 120Hz I am unable to think of anything over it.

Windows 10 is a real pain trust me I miss Windows 7. Well I say upgrade your Windows to its latest version and hope and pray that it solves the problem. As I can see you are still running older version of Windows unless you updated the OS in past 4days.

I say reinstall your GPU drivers as well.

Try running Chrome with Hardware Acceleration turned off whiled tuning the frequency of monitor to 120Hz.
 

helper800

Distinguished
Aug 12, 2011
697
54
19,140
29
Are you using wired keyboard and mouse or a wireless ones. If using wireless try the wired. If using wired and still getting the problem with display frequency lowered to 120Hz I am unable to think of anything over it.

Windows 10 is a real pain trust me I miss Windows 7. Well I say upgrade your Windows to its latest version and hope and pray that it solves the problem. As I can see you are still running older version of Windows unless you updated the OS in past 4days.

I say reinstall your GPU drivers as well.

Try running Chrome with Hardware Acceleration turned off whiled tuning the frequency of monitor to 120Hz.
1. Both my mouse and keyboard are wired.

2. I tried the latest version of windows and reverted due to some other issues, but it did not solve this problem.

3. I have tried running chrome with hardware acceleration on and off with both 120 hz and 144 hz on the main monitor. No change there.
 

helper800

Distinguished
Aug 12, 2011
697
54
19,140
29
For now continue using it as it is. In future with updates to Windows and NVIDIA drivers let's hope it gets patched on its own. If not then RMA GPU and it should solve the problem.
This happened with both a friend's 2070, my old 970, and my new 2070S. I do not believe it is a graphics card issue, however, it could be a driver issue or a Win10 issue.
 

helper800

Distinguished
Aug 12, 2011
697
54
19,140
29
Yeah then will have to wait till it gets patched up on its own.
I found this in the newest Nvidia driver patch notes. Is this related to my issue maybe?

"Windowed NVIDIA G-SYNC is Disabled During Video Playback on a Multi-monitor System Issue Beginning with Windows 10 April 2018 Update (RS4), NVIDIA G-SYNC is disabled during active video playback on multi-monitor systems. Explanation If hardware accelerated video is playing on one display and an application is launched on another display in windowed mode with NVIDIA G-SYNC or adaptive-sync enabled, the video stutters. This is the result of desktop compositing on displays with differing refresh rates. To prevent the video stutter in this scenario, the driver disables NVIDIA G-SYNC during active video playback, but re-enables G-SYNC if the video is paused or closed.

Note: The issue can also occur when displays are set to different refresh rates, even when G-SYNC is not used. To resolve in this case, make sure all displays are set to the same refresh rate."

Source: http://us.download.nvidia.com/Windows/436.48/436.48-win10-win8-win7-release-notes.pdf
 
I found this in the newest Nvidia driver patch notes. Is this related to my issue maybe?

"Windowed NVIDIA G-SYNC is Disabled During Video Playback on a Multi-monitor System Issue Beginning with Windows 10 April 2018 Update (RS4), NVIDIA G-SYNC is disabled during active video playback on multi-monitor systems. Explanation If hardware accelerated video is playing on one display and an application is launched on another display in windowed mode with NVIDIA G-SYNC or adaptive-sync enabled, the video stutters. This is the result of desktop compositing on displays with differing refresh rates. To prevent the video stutter in this scenario, the driver disables NVIDIA G-SYNC during active video playback, but re-enables G-SYNC if the video is paused or closed.

Note: The issue can also occur when displays are set to different refresh rates, even when G-SYNC is not used. To resolve in this case, make sure all displays are set to the same refresh rate."

Source: http://us.download.nvidia.com/Windows/436.48/436.48-win10-win8-win7-release-notes.pdf
Hope this patches it up for you. And yes run both at 60fps(if that is max for one monitor or the other) and see if the problem still occurs. But first try running without setting both of them to same refresh rate. If it gets solved that way it is better not to play with the settings any further.
 

helper800

Distinguished
Aug 12, 2011
697
54
19,140
29
Hope this patches it up for you. And yes run both at 60fps(if that is max for one monitor or the other) and see if the problem still occurs. But first try running without setting both of them to same refresh rate. If it gets solved that way it is better not to play with the settings any further.
Changing both monitors refresh rates to 60hz helps but not fix the stuttering when dragging the cursor between monitors while the video is playing. This defeats the purpose of having a 60hz+ monitor though so ill keep it at 120 hz for now. The dropped frames I experience do not subside with this change. I guess I will just live with this until it either gets fixed or I start using only 1 display.
 

ASK THE COMMUNITY

TRENDING THREADS