Question I bought another set of ram 16x2 @3200 MHZ NO DISPLAY @3200MHZ

Jun 7, 2022
3
0
10
0
Need help. I just bought and inserted another set of ram 16x2 - 32 GB @ 3200mhz the currently installed on my cpu is the same brand and specs and speed. after i inserted it. It says cleared cmos enter f1 for set up ... something like that then after I chose setup I entered bios and change frequency to 3200 MHZ it was set to 2133 when I first saw it and reads 64gb which it should be. But then after the adjustment when I try to reboot no display at all just running fans and CPU DEBUG led lit up red. What I did to fix the issue is take out battery cmos and it works but Frequency is set again to 2133 MHZ. Then its just a loop.

Bios is update. 5-2022 ver.
Specs
Mobo X570 MSI pro carbon WIFI
RAM Gskill trident z neo 16x2 @3200 mhz ( 2 sets - total of 4 sticks )
CPU Ryzen 7 5800x

Thank you in advance!
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Are you on BIOS version 7B93v1G1(Beta version) ? If so, try working with the new sticks of ram standalone, both in default state and in X.M.P/overclocked mode. See if the issue persists. Have you tried to clear the CMOS, after disconnecting the platform from the display and wall outlet?

Your specs are missing a coupe of things, your storage, chassis make and model, PSU and it's age.
 
Jun 7, 2022
3
0
10
0
Thanks for the warm welcome :)

Havent tried that with the new sticks. But the current sticks im using runs smoothly @ 3200mhz. But will definitely try that and update. I have tried to clear CMOS because its the only way for the cpu to get display again after ive tried adjusting the frequency up resulting to no display. Most parts of my CPU are brand new. aside from MOBO which is 1 year old sealed when I bought it. just built this cpu 4 months ago.

Specs :

PSU - 750RX Corsair
SSD - 512 GB WD Blue
HDD - 4TB WD Green
GPU - RTX 3060
CPU Cooler - Lian li galahad 120mm
 
Jun 7, 2022
3
0
10
0
Hi Just worked now! I saw the sticker on the box of the sticks written with the timings says 1,35V and tried applying it on bios. On bios it was set to 1.2V. It worked!
 

ASK THE COMMUNITY